Subject: Re: name service (does anyone else see this?)
To: None <current-users@NetBSD.ORG>
From: Simon J. Gerraty <>
List: current-users
Date: 07/18/1995 18:06:18
Just another data point... NetBSD/i386 -current-950508 btw.
[I'm also talking about not telstra :-)]

The other night my daughter started complaining that she could not
access any of the URLs she wanted via netscape.  Netscape kept
claiming it could not resolv the host name.  These were hosts that
she had been getting pages from only an hour or so earlier.

I run named locally to cache answers and to serve the local net I use
a forwarders line to my ISP for unknown stuff.

The ppp link was up (had been for a few days), I ran tcpdump on the
ppp link and could see the queries being forwarded to my ISP and what
looked like valid answers returning.

With an anxious 13 yr old trying to finish a project for school I
didn't muck around for long.  I reloaded named, no effect.  I added a
forwarder line to another name server who's joy in life is to act as a
DNS cache for Australia, no effect.  I killed and restarted named and
all was fine again.

Sounds like named cache corruption.

If it happens again, I'll investigate more fully...