Subject: A new user's comments, part 4
To: None <>
From: Scott L. Burson <>
List: current-users
Date: 06/04/1995 23:15:59
   Date: Sat, 03 Jun 1995 18:09:47 +0200
   From: Havard Eidnes <>

   >    Check your resource limits, can be done with the "limits"
   >    command in the C shell.
   > Thanks!  (I do feel a little silly for not having thought of
   > that, but I'm not used to those limits being set...)

   Did it help any?  Do you have your Franz Allegro Common Lisp
   running now?

No, alas.  `unlimit' expanded the data size limit from 16MB to 64MB, big
enough to start Lisp (but not big enough in the long run -- is this 64MB a
kernel parameter somewhere?).  However, when started Lisp now exits
immediately with "IOT trap".  I tried running it under GDB and the same thing
happened -- the program took a SIGABRT and died, even though I had told GDB
not to pass SIGABRT through to it.  Looks to me like it's getting the signal
not because of something in the code, but because the kernel doesn't like
something about the executable, and can't even get it started.  Anyone have
any ideas about this?

My most serious problem at the moment is this.  I just spent a few hours
trying to get my SLIP dialout to work.  The SLIP code that comes with NetBSD
seems to be a fairly early version and not to support dialouts (in particular,
there's no support for it in `tip').  The CSLIP-2.6 version of `tip' works,
sort of, but the CSLIP-2.6 `sliplogin' doesn't -- it gets "Inappropriate ioctl
for device: I_PUSH".  I guess this is a STREAMS call, which is some System V
thing that SunOS happens to support, but I'm hazy on this.  Anyway, the NetBSD
`sliplogin' exits after the connection is established, leaving it connected,
and giving me no way to shut down the connection that I know of (with CSLIP
under SunOS, `sliplogin' sleeps after the connection is made, and killing it
will hang up the phone and remove the routing table entry).  Conclusion: there
doesn't seem to be any usable dialout SLIP capability.  Does anyone out there
have a working SLIP dialout?  I guess I can switch over to PPP, if Netcom will
cooperate, but this is a pain.

There are some difference in the tty driver vis-a-vis SunOS that are causing
some minor problems.  Programs like `tip' can't open the serial port if CLOCAL
is not set, but, seems to me, it *shouldn't* be set on modem lines.  I tried
making `tip' open the port with O_NONBLOCK, but that is not sufficient -- it
can open the port, but then can't write to it.  I guess it will have to open
the port with O_NONBLOCK, immediately set CLOCAL, then clear CLOCAL once
dialing is complete (but only if it really did dial, and didn't just connect
to the port).  Really, I think I prefer the SunOS interpretation of CLOCAL,
which appears to be just to generate SIGHUP on an on-to-off transition of DCD
and to ignore DCD otherwise.  But NetBSD's behavior is at least consistent
with its documentation.

Another problem is that I can't rebuild any of my executables that use X11-R5
libraries, because the latter were compiled under SunOS, and it doesn't work
to build a NetBSD executable that references SunOS libraries.  As I mentioned
a few days ago, the SPARC X11-R6 binary distribution on appears
to be corrupted.  My other choice would be to rebuild X11-R5 under NetBSD, but
that looks like a project and a half.

I'm not sure how much more time I want to put into attempting to switch over
to NetBSD.  From my point of view, it still seems pretty rough -- of course, I
exercise some aspects of the OS that not everyone cares about.  If relatively
easy solutions appear to these problems, I might keep trying, but otherwise
I'll just call it a learning experience and maybe give it another shot in a
year or so.

-- Scott