Subject: Trying to update to current from source
To: None <current-users@NetBSD.ORG>
From: None <aellwood@MIT.EDU>
List: current-users
Date: 03/23/1995 18:12:41
Hi, a week and a half ago I downloaded the current source (right after
COMPAT_LINUX came out) to update from 1.0.  I recompiled
and as, and then tried to build myself a new kernel based on the
generic kernel (with COMPAT_1.0).  The kernel built fine, and when I
booted all my devices came up just fine.  But when it tried to run
/etc/netstart and ifconfig my SMC Elite 16C Ultra ethernet card, it
started spewing "Invalid packet length - NIC Memory Corrupt" or
something like that all over the screen and the machine began
thrashing.  It was also spewing a second line that contained a
non-zero packet length -- something in the thousands.  After 10
minutes I managed to log in through the error messages and tried to
sync and reboot.  On reboot the machine hung and display all sorts of
weird colored characters.  This was multiuser.

So I figured it was the same error I had before with the kernel being
configured for 2 floppy drives when I only have 1 (although that time
the packet length had been 0).  I checked my kernel config file and
there was only one floppy drive configured.  

So I tried rebooting single-user and managed to get the card to ping
my gateway on the second ifconfig (though this is normal -- in NetBSD
1.0 I have to ifconfig twice to keep ping from generating the error
"arpresolv" -- may be two r's there).  So the card does still work.
Reboot still caused the machine to hang flashing weird characters.

I tried booting multiuser a third time and got the same error...right
after /etc/rc gets to the part where it echos "printer" -- Not sure if
that's significant since it may just be delayed.  Then I gave up.

I have a P90, SMC Elite16C Ultra, NCR SCSI-2 card, Mach64, Sound Blaster16.

Anybody seen anything like this?

Alexandra Ellwood