Subject: Re: disklabel fails for SCSI drives
To: None <current-users@NetBSD.ORG>
From: Graham Norbury <>
List: current-users
Date: 03/23/1995 10:15:03
>I can't seem to get NetBSD/i386 1.0A to write to the disklabel of a
>SCSI disk anymore.  Floppies still work.
>I used "disklabel -w -r sd2 hp_mo" under 1.0A and it fails to install
>a label on new media.  It does not seem to damage existing lables in
>the effort though.
>I booted 1.0 from floppies and it works.
>I used "newfs /dev/rsd2a hp_mo" under 1.0A and it fails to update the
>disklabel after creating the filesystem.
>Again 1.0 succeeded.


>Do other people get this too?  Is this a known problem?  Should I send-pr it?

I have had all manner of disklabel problems when trying to upgrade to current.
Basically under 1.0 everything worked ok but from 1.0A disklabel kept returning
and complaining about Read Only file systems an such.  (Even after doing a
disklabel -W sd1 etc).

Finally though it seemed to have written both the label and the boot blocks 
despite complaining and several reboots, but then newfs barf'd saying it
couldn't update the disklabel ? (Even though it worked afterwards...)

Maybe the recent updates to disklabel and newfs have fixed this ??

Graham Norbury