Subject: Still No Install
To: None <current-users@NetBSD.ORG, tech-install@NetBSD.ORG>
From: Michael Endrizzi <>
List: current-users
Date: 03/15/1995 10:06:29

      1 gig ide running dual drive emulation 504meg/504meg (1024c,16h,63s)
      split OS's, NetBSD on drive 1 and MSDOS on drive 2


      install/disklabel always ignores my FDISK partition info and
      then creates its own on cylinders 0->49 and claims it is
      50,000 sectors long (actually 50*63=3,150 sectors) BUT the
      NetBSD disk label info contains the correct size info i
      used during the install.
      linux installs no problem


      1) Eric Hvozda told me to use pfdisk and all my problems go away
         but i'm back where i started. i tried using linux fdisk, o/s2
         fdisk, norton utils diskedit. The MSDOS pfdisk i used was from 1991,
         Is there a more recent one and where is it?
      2) The MSDOS pfdisk reports the drive is 1023 cylinders but NetBSD
         says its (correctly) 1024 cylinders. Who do i believe and what numbers
         do feed to the install (i've tried both)
      3) During the install, it asks for offset in cylinders to NetBSD
         partition. I've specified zero (0). Now the question is, "where
         is cylinder 0?". Is it the first cylinder on the drive (i.e. sectors
         0->62), or the second (63->125). How does NetBSD account for the MBR
         on sector 0? I'm thinking that the NetBSD disklabel and FDISK info
         are not in synch at this point because they start in different
      4) I'm convinced i have an old version of disklabel. The error
         messages i get:

                    disk label not found
                    Overwriting DOS partition [n]:

         do NOT appear in the source code. I am using inst-10.fs
         from NetBSD-current. Does ftp:ftp.netbsd.or:NetBSD-current/inst-10.fs
         have the current disklabel or not?