Subject: problem compiling current kernel
To: current-users <current-users@NetBSD.ORG>
From: John Maier <>
List: current-users
Date: 03/13/1995 16:23:00
I'm trying to compile the current kernel, download today (3-13) off of  I finally got the new config working, did a make depend
and when I tried a make I get...

as: ../../i386/locore.s:310: no such 386 instruction: `cpuid'
as: ../../i386/locore.s:317: no such 386 instruction: `cpuid'
as: ../../i386/locore.s:1878: bad register name ('-138422880r6')
as: ../../i386/locore.s:1881: bad register name ('-138422880r6')
*** Error code 1

never had this happen before!

I've never had problem with NetBSD 1.0 i386.  I am using the gcc that came 
with the 1.0 distribution.

I went into ../../i386/ and found that there is a locore.s.old, I saved off 
locore.s, copied locore.s.old to locore.s and tried continuing the build, it 
worked for awhile then died again.



*       John A. Maier          * Research Assistant For Datastorm    *
* E-mail: * Technologies Inc. (Procomm Plus)    *
* AOL:    * (314) 443-3283                      *