Subject: Re: ppp and NetBSD-current
To: Ignatios Souvatzis <>
From: Rafal Boni <>
List: current-users
Date: 03/04/1995 04:58:05
[I'm forwarding a copy to tech-net, but also to current-users in case
more people have actually seen this....]

In message <>, you write: 

-> Bernd told me about his problems with ppp and -current twice, and
-> I run into the same one after upgrading the kernel.
-> (I think I didn't have it with the 1.0 kernel)
-> Description: TCP performance an large (e.g. FTP) transfers slows
-> down to ~10% of the nominal line capacity. more precisely, after the
-> first few K have been transferred quite fast, the transfer stops for 
-> lots of minutes.

	Yeah, I've seen this happen before.  It usually bites me while I'm
	trying to do last-minute FTP's of stuff I need to hand in either to
	the Sparc [Solaris 2.3] or directly to our QMS printer.  I'm always
	in too much of a hurry to track it down and generally end up putting
	stuff on floppy and being late to class ;-(

	I *am* using SLIP 99% of the time, because I've got Mark Weaver's
	nifty SLIp program that does all the things I want my PPP to do and
	haven't had the time to set up [ie, keeps dialing till it gets a 
	modem, passes the Cisco my username/passwd,...]

-> I guessed some VJ problem, after trying it myself. So a few minutes
-> ago I tried to transfer the same file I got yesterday with ~100
-> bytes/s, but started pppd with -vj. I got 1926 bytes/s (V32bis modem with
-> compression enabled), so I think that is it. Bernd, this is my proposed
-> workearound for you until the real problem is fixed.

	Do you see this regularly enough to say that it's fixed after one try?
	For me, this is an on-and-off thing.


+--------------------------------------------------------+ +------------------+
| In search of the stress-strain relationship governing  |/|       Rafal Boni |
| students of mechanics... Experimentally.               |\| |
+--------------------------------------------------------+ +------------------+