Subject: Re: XFree86-3.1.1
To: None <current-users@NetBSD.ORG>
From: thecure <>
List: current-users
Date: 03/04/1995 21:52:52
Forwarded message:
>From daemon Sat Mar  4 21:52:03 1995
Date: Sat, 4 Mar 1995 21:52:03 +1100
From: Mail Delivery Subsystem <MAILER-DAEMON>
Subject: Returned mail: User unknown
Message-Id: <>
To: mda
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="VAA04336.794314323/"

This is a MIME-encapsulated message


The original message was received at Sat, 4 Mar 1995 21:50:40 +1100
from mda@localhost

   ----- The following addresses had delivery problems -----  (unrecoverable error)

   ----- Transcript of session follows -----
... while talking to
>>> RCPT To:<>
<<< 550 <>... User unknown
550 User unknown

   ----- Original message follows -----

Content-Type: message/rfc822

From: thecure <mda>
Message-Id: <>
Subject: Re: XFree86-3.1.1
Date: Sat, 4 Mar 1995 21:50:39 +1100 (EST)
In-Reply-To: <> from "Tsuyoshi TADA" at Mar 4, 95 00:56:23 am
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit
Content-Length: 1360      

> On Fri, 03 Mar, (Brian D. Carlstrom) writes:
>  > I just upgraded to a -current kernel from a jan 16 -current kernel
>  > and X doesnt work. it says it can't mmap /dev/vga. i tried upgrading
>  > from Xf86 version 2.x to 3.1.1.
>  > 
>  > any ideas?
> It seems that you have to use NetBSD aperture driver.  If you want to 
> build XFree-3.1.1 from source distribution, make sure the following
> definition in your site.def or directly:
> 	#define HasNetBSDApertureDriver YES

>From the README.Netbsd

  There are two ways to allow XFree86 to access linear memory:

     1. Disable the kernel security feature by initializing the
        ``securelevel'' variable to -1 in /sys/kern/kern_sysctl.c, line
        205 and building a new kernel. For more informations, see the
        comments in /usr/include/sys/systm.h.

     2. Install the NetBSD aperture driver:

        a. add the following lines to the end of /etc/rc.local:

              if [ -f ${KERNDIR}/ap.o ]; then
                modload -o ${KERNDIR}/ap -e ap -p ${KERNDIR}/apinstall ${KERNDIR}/ap.o

I defined HasNetBSDApertureDriver YES, and thought everything was cool. But.

I never saw the aperture driver built. Is it part of X11R6? I can't find it.

I used method 1, and it worked.