Subject: Re: problems in libg++-2.6.2 compile
To: Rob Healey <>
From: Ken Hornstein <>
List: current-users
Date: 02/18/1995 18:04:35
>	Libg++ creates a _G_config.h file in libio. This file defines
>	some types based on quad_t and int64_t which are in sys/types.h
>	of the system. No problem, except the files which use _G_config.h
>	include it BEFORE including sys/types.h and then gcc 2.6.3 gets
>	upset about quad_t and int64_t not existing yet.
>	All I did was run config in the top level directory, do you have to
>	do more than that to get libg++-2.6.2 to compile under gcc-2.6.3
>	under NetBSD-current?

Unfortunately, no, that's not all you need to do.  I solved this by adding
an #include <sys/types.h> in _G_config.h.

It gets worse, however.  Somewhere along the way you'll get a mismatch
between a function that's declared as int with unsigned int arguments.  I
solved that by copying over the functions and declared them as unsigned int.

>	I can't use the system gcc/g++ and libg++ since the C++ code I have
>	can't compile under the older gcc/libg++ combo B^(.

John Kohl said he got HylaFAX working with gcc 2.6.3 but with the NetBSD
supplied libg++.  You might want to try that first.