Subject: Problems with ed driver with NetBSD-1.0
To: None <>
From: Brian Moore <>
List: current-users
Date: 12/14/1994 22:49:25
I just purchased a Micron PowerStation P90 with the BusLogic 946C PCI SCSI-2
controller.  When I try to install NetBSD on this machine, everything works
with the installation except whenever I try to enable my SMC 8216C EtherNet
board, it starts shooting back the error message 

"ed#: NIC memory corrupt - invalid packet length 0"

This happens when I have the card set for ed0 (0x280, 2, 0xd000) or ed2 (0x300,
10, 0xcc00).  I assuming that either the OS can find the card's RAM, or there's
a conflict between the PCI board and the card's RAM.  Another thing that it is
complaining about is it can't configure the PCI devices.  Here's the PCI probe

moby /netbsd: pci0 at isa0 port 0x0-0x665: configuration mode 2
moby /netbsd: pci0 bus 0 device 0: identifier 04a38086 class 06000011 not configured
moby /netbsd: pci0 bus 0 device 2: identifier 04848086 class 00000003 not configured
moby /netbsd: pci0 bus 0 device 13: identifier 0140ffff class 01000000 not configured
moby /netbsd: pci0 bus 0 device 14: identifier 88d05333 class 00010000 not configured

I have a strange feeling these might be part of the cause.  Of course, I'm
clueless about how to decode these.  The really weird thing about all this is
that I tried to install FreeBSD 2.0 on the same machine and not only did it
configure the PCI devices, but the ethernet card worked fine.  Has anybody got
any idea what I have to do to get NetBSD to work on this machine?