Subject: Did /bin/csh change?
To: None <>
From: Mark Tamola <>
List: current-users
Date: 12/11/1994 15:53:23
Dear sirs,

For some odd reason, my /bin/csh doesn't work correctly anymore, and 
since I don't recall anyone complaining about it before, I just want to 
portray my experiences here:

1.  Upon loggin in, I get the following message as root:

	Warning: exported path contains relative components.
	Unknown variable modifier.

    and the following message as a regular user:

	Unknown variable modifier.

2.  I thought it was some stupid typo in one of my startup files, (i.e.  
.cshrc, .login, .logout, etc.), but it can't be.  I tediously commented 
out each line, or groups of lines, of each and every startup file, and I 
still get the same error message when either logging in at the console or 
starting a new xterm when I'm in X.  I have also checked for any 
conflicting things with any global startup files (i.e. /etc/csh.cshrc), 
and still no go.

3.  This also causes some wierd error when using term with kermit, as 
when I start term on the remote computer, I can't escape to get back to 
kermit, and the kermit process becomes hung until I kill -9 it.  Thus, I 
can't use term, and thus I can't sup! 8-(.  (Although not NetBSD 
specific, just an example of a problem it causes).

4.  I don't have any of the above problems when using /bin/sh, and no 
problems with any other programs when using /bin/sh, either.

Thanks for any suggestions.

Mark Steven de Sagun Tamola