Subject: Re: Oddball network misbehavior
To: John F. Woods <>
From: Michael L. VanLoon -- <>
List: current-users
Date: 12/09/1994 22:23:42
"John F. Woods" <> writes:
>I've just gotten an Internet link for my home system, a PPP link through
>UltraNet Communications.  I've been happily grabbing stuff from systems all
>over the Internet -- but I can't reach MIT.  If I try to ping systems at MIT,
>nothing happens (I don't even see the modem lights flash, which is interesting
>but possibly meaningless) (note that I am able to correctly look up their
>IP addresses).  If I telnet out to some site I can reach, and telnet from ther
>to a machine at MIT, and then ping my home system, it also fails to work, BUT:
>I do, in that case, seem to see regular modem activity!  (The MIT site is able
>to ping the gateway on the other end of the PPP link.)

I saw exactly this same thing.  I also couldn't reach  When I removed my static default route (so the
only route was the one that pppd installed (with the defaultroute
option) when it started), all the problems went away.  Dunno why.

So, with the default route installed via the route command, things
broke.  But with pppd's defaultroute, it worked fine.  I think somehow
the system interprets the IP numbers for these hosts (class A nets) in
such a way that the netmask gets messed up or something.  With the IP
#'s 16.x.x.x and 18.x.x.x this problem appears.  All the other hosts I
tried to reach had numbers like 129.x.x.x, 133.x.x.x 198.x.x.x.

This is must my observation.

   Michael L. VanLoon
  Free your mind and your machine -- NetBSD free un*x for PC/Mac/Amiga/etc.
     Working NetBSD ports: 386+PC, Mac, Amiga, HP300, Sun3, Sun4c, PC532
               In progress: DEC pmax (MIPS R2k/3k), VAX, Sun4m