Subject: mild debugging problems and WWW?
To: None <>
From: John F. Woods <>
List: current-users
Date: 12/07/1994 08:04:44
I have had some problems with gdb running the 1.0 binaries (I haven't been able
to update since then, since my convenient ftp access went away; soon that should
be fixed).  I have been trying to compile the "chimera" WWW browser, and first
found that if I ran gdb on the dynamically linked binary, my system locked up
(no response whatsoever on the console or on a telnet connection that was open
at the time; hmm, I forgot to try ping.  oops.).  [If this "should" have worked,
I'll be happy to try to reproduce it and submit a better report.]  With a
statically linked binary, gdb worked OK until it was time to analyze the
halted program, whereupon it began complaining that it couldn't read pieces
of memory because of illegal requests.  I traced that down to some lseek calls
in need of off_t casts (I can supply diffs if that hasn't been fixed).  Once
that was fixed, gdb appeared to work, and I was able to get chimera to stop
core dumping (but not to work, something else odd is going on inside it).

While I'm here, has anyone compiled an HTTP server and browser set and gotten
them to work, so I can just ftp the binaries and be done with it?  Thanks.
John Woods,