Subject: Better Problem Report...
To: None <>
From: Dave Burgess <>
List: current-users
Date: 12/02/1994 18:12:36
Sorry about the brevity of my last message, I was trying to get it out
under the wire.

My lpd process seems to be dead.  I can start the 'parent' lpd, but
subsequent lpd jobs (like to print a document) abort and leave a
lpd.core in the /var/spool/lpd directory.  The error message that is
generated by gdb is:

(no debugging symbols found)...
(gdb) Starting program: /usr/sbin/lpd 
reading register eip (#8): Invalid argument.

There is no stack to trace and no other information seems to be
forthcoming from gdb.

Here is the dmesg for my system:

NetBSD 1.0A (CYNJUT) #1: Mon Nov 28 11:53:08 CST 1994
CPU: i386DX (386-class CPU)
real mem  = 33161216
avail mem = 29388800
using 430 buffers containing 1761280 bytes of memory
isa0 (root)
npx0 at isa0 port 0xf0-0xff irq 13
pc0 at isa0 port 0x60-0x6f irq 1: color
com0 at isa0 port 0x3f8-0x3ff irq 4: ns82450 or ns16450, no fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns82450 or ns16450, no fifo
com2 at isa0 port 0x3e8-0x3ef irq 5: ns16550a, working fifo
lpt0 at isa0 port 0x378-0x37f: polled
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
fd1 at fdc0 drive 1: 1.2MB 80 cyl, 2 head, 15 sec
mcd0 at isa0 port 0x320-0x323 irq 10: model LU005S
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
wd0 at wdc0 drive 0: 329MB, 790 cyl, 15 head, 57 sec, 512 bytes/sec <Maxtor 7345 AT>
wd0: using 16-sector 16-bit pio transfers, chs addressing
wd1 at wdc0 drive 1: 405MB, 989 cyl, 15 head, 56 sec, 512 bytes/sec <WDC AC2420H>
wd1: using 16-sector 16-bit pio transfers, chs addressing
wt0 at isa0 port 0x338-0x339 irq 9 drq 3: type <Wangtek>
ed0 at isa0 port 0x280-0x29f iomem 0xd0000-0xd3fff irq 15: address 00:00:c0:57:95:69, type WD8013WC (16-bit) bnc
biomask 4640 netmask 803a ttymask 3a
changing root device to wd0a

As you can see, the printer is set up as the polled device (as it has
been since I started with 0.8) and is set to not reset (I was using the
non-resetting minor number).  I tried the /dev/lpt0 and the /dev/lpa0
devices as well.  Always the same problem.

The error-log is not much help, since all it tells me is that a new
daemon was started...

I was reading the /usr/share/doc/07.lpd/paper and it seems to think that
lpd needs to be installed as setuid root.daemon and all of the files and
directories need to be set to allow daemon access.  The lpd Makefile
installs it as mode 555 bin.bin.  Which one is correct?

That, by the way, is not the problem either.  I tried resetting the
ownership and directories to the recommendations in the doc file, and
the lpd job still dumps core.

That's it.  I'm pretty well stumped.