Subject: installing NetBSD-1.0 (beta?)
To: None <>
From: Simon J. Gerraty <>
List: current-users
Date: 11/08/1994 09:27:36
Ok, after the generic kernel paniced (lppanic: timeout table full)
I loaded the Oct24 src tar_files and crafted a new kernel config (from
GENERICAHA, SUNL-LAMP and my old ZEN) I'll enclose it at the end.
I config'd, make depended and made this kernel.
I made a new kernel copy floppy using:

	gzcat kcaha-10.fs.gz | dd bs=147456 > /dev/rfd0c

I think that was my next problem and should have spotted it when fsck
/dev/rfd0a barfed but /dev/rfd0c worked fine...
Anyway, I had to strip the new kernel to fit it on that floppy...
When I booted from it, it reset the machine as soon a the new kernel
started running...

I commented out a new non-essentials, made clean, depend and a new
kernel.  Then re-made the floppy with

	gzcat kcaha-10.fs.gz | dd bs=147456 > /dev/rfd0a

and the kernel fitted fine and booted better!

Great.  Time to try modems etc...

To cut a _long_ story short(er), all my old Feb12 binaries worked fine
except nnmaster kept claiming it was being with "nnmaster: invoked
with wrong user privileges" it was as if the set-uid bit was being
ignored.  I suspect some set*uid() call was failing.

Q. is there a document somewhere which lists system calls etc that used
to work in 0.9a but do not in 1.0 ?

More alarming was that MHSnet failed to start.  The error was:

	     NETWORK STARTED Mon Nov 7 07:29:21 PST 1994
	available free space on /var/spool/MHSnet/ is 120634 Kbytes
	==== netstate -ersxC
	94/11/07 07:29:21 netstate: system error -- Could not lock "/var/spool/MHSnet/_state/lock": Invalid argument

The lock file _was_ being created ok, but that error message was the
consistent result.  This is more a problem as I don't have source to
MHSnet - its a binary only commercial app compiled for BSDi.

Q. flock or fcntl semantics changed recently?

I had to re-start with 0.9a to be able to get this message out (MHSnet
is the carrier :-) fortunately this is just a case of disabling the IDE
drive in CMOS.


BTW I have DDB in the new kernel, but did not get around to trying lpr
again as I needed to resolve the MHSnet issue or swap back to uucp...
Here is the new config.

# GENERICAHA -- Generic machine w/aha driver -- distribution floppy
#	$Id: GENERICAHA,v 1994/10/17 21:51:32 cgd Exp $

machine		"i386"
cpu		"I386_CPU"
cpu		"I486_CPU"
#cpu		"I586_CPU"
ident		ZEN
timezone	-10
maxusers	24
options		FFS,MFS
options		"COMPAT_43"
options		"COMPAT_09"
options		"TCP_COMPAT_42"
#options		MSDOSFS
options		KERNFS
#options		KTRACE
options		SCSI
#options		"MATH_EMULATE"
options		"COMPAT_NOMID"

options	DDB
# Allows user to create an i386 LDT (Used by Wine to run Windows programs)
options		"USER_LDT"

options		FIFO			# fifos; recommended
options		SYSVSHM			# System V shared memory; broken
options		"SHMMAXPGS=256"
options		SYSVMSG			# System V-like message queues
options		SYSVSEM			# System V-like semaphores
options		LKM			# loadable kernel modules
options		QUOTA			# quotas in UFS

options		"LP_SIMPLE_PROBE"	# always find printers :-)

config		netbsd	root on wd0 swap on wd0 and sd0 and sd1 and sd2

#config		netbsd	swap generic
#options		GENERIC

controller	isa0

device		pc0	at isa? port "IO_KBD" irq 1
device		com0	at isa? port "IO_COM1" irq 4
device		com1	at isa? port "IO_COM2" irq 3
## 3rd serial port configured as COM3 on IRQ2
device		com2	at isa? port 0x2e8 irq 9

device		lpt0	at isa? port "IO_LPT1" irq 7
device		lpt1	at isa? port "IO_LPT2"
device		lpt2	at isa? port "IO_LPT3"

controller	wdc0	at isa? port "IO_WD1" irq 14
disk		wd0	at wdc0 drive ?
disk		wd1	at wdc0 drive ?

controller	fdc0	at isa? port "IO_FD1" irq 6 drq 2
disk		fd0	at fdc0 drive ?
disk		fd1	at fdc0 drive ?

#device		wt0	at isa? port 0x300 irq 5 drq 1

controller	aha0	at isa? port "IO_AHA0" irq ? drq ?
master		scsibus0 at aha0
disk		sd0	at scsibus0 slave ?
disk		sd1	at scsibus0 slave ?
disk		sd2	at scsibus0 slave ?
disk		sd3	at scsibus0 slave ?
disk		sd4	at scsibus0 slave ?
tape		st0	at scsibus0 slave ?
tape		st1	at scsibus0 slave ?
disk		cd0	at scsibus0 slave ?
disk		cd1	at scsibus0 slave ?

device ed0 at isa? port 0x280 net irq 5 iomem 0xd0000 vector edintr

#device ed0 at isa? port 0x280 irq 9 iomem 0xd0000
#device ed1 at isa? port 0x250 irq 9 iomem 0xd8000
#device ed2 at isa? port 0x300 irq 10 iomem 0xcc000
#device el0 at isa? port 0x300 irq 9
#device ep0 at isa? port ? irq ?
#device ie0 at isa? port 0x360 irq 7 iomem 0xd0000
#device le0 at isa? port 0x320 irq 10 drq 7

device		npx0	at isa? port "IO_NPX" irq 13

pseudo-device	ether
pseudo-device	log
pseudo-device	loop
pseudo-device	pty	64
pseudo-device	sl	2
pseudo-device	ppp 2				# Point-to-Point Protocol
pseudo-device	bpfilter 6			# packet filter
pseudo-device	speaker