Subject: Re: CAP and ethernet address
To: None <>
From: Andrew Gillham <>
List: current-users
Date: 10/27/1994 14:47:42
> I am trying to get CAP (phase 2 appletalk, not phase 1) working on NetBSD.  
> Once I redid the m4 configuration macros to allow this, I got it to compile.
> However, when I would run "aarpd" (the daemon that talks appletalk to the 
> net) it would die with:  "Ioctl: SIOCGIFADDR: Invalid argument".  After some
> poking I found that the code was dying when it tried to get the address of 
> the ethernet card.  Hardcoding my ethernet address solved the problem.

I have this problem also... and have it hard-coded on 2 different
machines... :-)  If you do get a solution, let me know if you get a

> Presumably this code works on other platforms.  Does NetBSD have any 
> oddities or known bugs in this area?  Hardcoding the information is not my 
> workaround of choice, since this code must work on several machines.

Works on a Sun, but then it's not using bpfiltp.c on the sun.

> I am running current (as of a week or two) on a 486.  The ethernet card is a
> SMC Ultra.  I haven't been able to test this with any other cards or 
> machines.

Same problem on:
	Dell 466SE EISA
	3C579TP 3com EISA 10Base-T
	NetBSD v1.0BETA

	486DX2/66 ISA clone
	3C509TP 3com ISA 10Base-T
	NetBSD v1.0BETA