Subject: CAP and ethernet address
To: None <>
From: Kevin Sullivan <>
List: current-users
Date: 10/27/1994 10:18:51
I am trying to get CAP (phase 2 appletalk, not phase 1) working on NetBSD.  
Once I redid the m4 configuration macros to allow this, I got it to compile.
However, when I would run "aarpd" (the daemon that talks appletalk to the 
net) it would die with:  "Ioctl: SIOCGIFADDR: Invalid argument".  After some
poking I found that the code was dying when it tried to get the address of 
the ethernet card.  Hardcoding my ethernet address solved the problem.

Presumably this code works on other platforms.  Does NetBSD have any 
oddities or known bugs in this area?  Hardcoding the information is not my 
workaround of choice, since this code must work on several machines.

The offending function is ioctl(fd,request,char*).  What (if anything) 
should the char* contain to make this work?

I am running current (as of a week or two) on a 486.  The ethernet card is a
SMC Ultra.  I haven't been able to test this with any other cards or