Subject: Re: partitioning MS-DOS problems -- aargh!
To: Ken Hornstein <>
From: Ian Fitchet <>
List: current-users
Date: 10/21/1994 18:53:30
 On Fri, 21 Oct 1994 12:55:30 -0400, Ken Hornstein <> said:

>I see from down below that it looks like you're running "disklabel fd0" ...
>is that right?  If so, I _think_ what's happening is that it's trying to use
>/dev/rfd0d.  The minor device numbers on the floppies are used to select
>drive densities, so if you just say "fd0" you'll get the wrong device.  What
>happens when you try "disklabel /dev/rfd0a"? (I freely admit this is all
>confusing :-) )

 Yes, that's true.  When I run `disklabel /dev/fd0a' it returns with
the ioctl error, when I do `disklabel /dev/fd0d' it spouts the fd0:
hard errors to the console and then echos the ioctl error.

>Well, it's supposed to be used to manipulate MS-DOS partition tables; if there
>ain't a MS-DOS partition table on the disk (which is usually the case if you
>install NetBSD on the whole drive) then it won't have much to do :-)

 OK, that's fair enough.

>1048?  I was under the impression you couldn't set the BIOS to more than 1023
>cylinders?  But I see from down below you tried a fake geometry, so obviously
>that's not the problem.

 Mine is the AMI BIOS 1.00.05AX1, my colleagues is the AMI BIOS
1.00.09AX1.  Whilst I don't doubt that we haven't tried all possible
combinations we have tried plenty (cyls=522, 524, 1048, 1024 etc.)

 Sorry, to make this drag on and on.  I hope you agree this is best
sorted before NetBSD leaves BETA testing.  (I can see myself not
winning many friends here :-) )



      Ian Fitchet
  Fujitsu Fulcrum Telecommunications ltd., Fordrough Lane, Birmingham, B9 5FL