Subject: Re: mount_ados checksum errors
To: None <lilly!NetBSD.ORG!owner-amiga>
From: Berndt Wulf <>
List: current-users
Date: 10/20/1994 18:46:58
:Hello again...
:  Since I got no response to my last message, I am trying one last desperate bid
:for a solution <grin>...

Well here one response at last:-)

:  I am trying to install NetBSD, following the install.amiga guide, and running into
:trouble when it comes to mounting the AmigaDOS partition where the distribution sets
:are living.  Basically, I can format the root & user partitions on the drive, and
:I can mount the AmigaDOS partition with (say)
:mkdir /mnt/ados
:mount_ados /dev/sd1d /mnt/ados
:If I actually try and use the AmigaDOS partition (to CD, grab a directory listing etc.
:let alone actually extract the distributions), I get checksum errors all the time.
:he AmigaDOS partition(s) in question patently *do not* have any filesystem errors, I
:have checked them very thoughroughly indeed from the miggy side :*).  I have tried
:to mount partitions freshly formatted, on the same physical drive as the NetBSD
:partitions, on a different physical drive, formatted with both 1.3 and 2.04 FFS etc.
:to no avail...
:Basically, has anyone experienced similar problems, and worked out how to fix it!?!

I had basically the same problem a few weeks ago. I was able to format and read/write the
ADOS-partition on the ADOS-site, but couldn`t use it on NetBSD. The partition in
question was previously used as a NetBSD-partition and than reformatted as a ADOS-
partition. The problem was, that I had no reserved blocks. After changing the number
of reserved blocks from 0 to 2, using the HD-Toolbox utility,  I was able to mount the
ADOS-partition on NetBSD.

Good luck

-- cheerio Berndt