Subject: Re: Print Errors
To: Gary D. Duzan <>
From: Mark Tamola <>
List: current-users
Date: 10/20/1994 21:17:03
On Thu, 20 Oct 1994, Gary D. Duzan wrote:

>    I've been having a problem with print errors for a while on an
> old Panasonic 9-pin printer. Thinking it was a problem with the
> printer I let it go, but I'm getting pretty much the same thing
> with a brand new DECwriter 100i Inkjet printer. The symptom is that
> I get text symbols, form feeds, etc., mixed in with my bitmapped
> data at irregular intervals. The data is generated by the djet500
> driver in GhostScript and piped to lpr. I got a good printout when
> there was a print job in the queue when it came up, though. Has
> anyone seen something like this?

I have, and I think I know exactly what you are talking about.  I was 
complaining about this very subject about a month and a half ago.  You 
might even see my message as well as a couple of replies in the mailing 
archives, and I posted this info as well.

I have an Epson Stylus 800 printer, and I get the same garbage from 
Ghostscript that you do.  No matter what I did, the printer would print a 
couple lines, then spit out a page for no reason, or lines in the print 
would get skipped with empty space, and the problems went on and on.  All 
due to the printer getting irregular characters.  Like you said, 
sometimes my printer would print a page fine, and other times it would 
just screw up, but it was completely random.

No matter if I used lpr or just straight out gs -q -dNOPAUSE...etc. the 
problems would remain.  I believed it was the driver, but when I mailed 
the author, he said that it works on his Linux box, but he knew nothing 
about NetBSD, so he couldn't really help me if it was a NetBSD specific 

Nothing I changed in my printcap worked neither.  It seems to be a 
problem in the driver or somewhere in the general program.  Both 
ghostscript 2.6.1pl4 and ghostscript 3.x don't work correctly.

Just to let you know, I am in the same boat as you, and to this day, my 
damn printer still doesn't print with ghostscript.  I guess I have to 
fork out the dough to buy a REAL postscript printer.

Keep me updated on any help you receive though.  Maybe someone has fixed 
this already.

Mark Steven de Sagun Tamola