Subject: Problems with new installation
To: None <current-users@NetBSD.ORG>
From: Brian Moore <>
List: current-users
Date: 09/23/1994 21:53:07
I just tried to install NetBSD 1.0B from the Sept. 16 installation sets on a
Dell 486 and almost everything is working great.  As long as I am root
everything acts like normal, but when I set up a user using vipw, and chpass
that user doesn't have access to certain parts of the system.  For example, the
command 'passwd' returns 'Permission denied: /etc/master.passwd' when run as
anyone but root.  Another one is the command 'w' returns '/dev/mem: Permission
denied' again for anyone but root.  I traced through passwd, and it's hitting
the error in getpwnam from libc, but for the life of me, I can't figure out
what it is missing.  I know this is going to be one of those 'Just set
permissions on xxx file/directory' or 'Add this to this file in /etc'.  I tried
to compare the entries in /etc with my machine at home, and everything seemed
AOK. Sorry for this weenie question, but can anyone point me to what I didn't
configure correctly because I'm kinda stumped right now.

Brian Moore