Subject: Bringing up NetBSD on a PCI based machine.
To: None <>
From: Brian Moore <>
List: current-users
Date: 08/26/1994 04:21:37
Is it possible to bring up NetBSD-current on a PCI based 486?  I just purchased
a new computer from Gateway2K, their 4D66 package which has a PCI based ATI
Ultra AXO video board, and a 740MB Enhanced IDE drive hanging on a PCI
controller.  I tried to install NetBSD-0.9 on it to bring it up to
NetBSD-current, but the disklabel keeps on failing.  pfdisk says that the drive
has 708 cyls with 32 heads, while the probe during boot lists the drive as
having 1416 cyls with 16 heads.  When I try to do the disklabel with the params
during the boot, it acts like it worked and the inst-01 floppy copies the files
to the disk.  I even run a few programs from /mnt and they work fine ( drive
light even flashes ).  But when I reboot to copy over the kernel to the disk it
complains that it can't mount the drive because the disk label is bad.  When I
check the drive with disklabel, all the parameters look fine except the number
of heads is not 16 but 32, and disklabel complains that the partition map is
overflowing the drive.  Next I I tried to use the disk params that pfdisk
reported, and now disklabel complains about wdctrlreset( -1 ) [some other error
] (-4) which causes a kernel panic.  

Now admittedly, I haven't brought up a machine with 0.9 since about 3 months
after it came out, so I'm probably forgetting things about the drive params and
other little things ( like when the install program asks for the mount point,
should you type /usr or just usr?  I thought one caused problems but I can't
remember which. )  Would it be easier to just bring NetBSD 0.9 up on a SCSI
drive hanging off of a 1542 and then just disklabel and transfer the files over
to the internal Enhanced IDE?  More importantly, has anyone else done this? (
PCI w/ Enhanced IDE ) or am I just wasting my time on something that isn't
ready yet. 

Thanks for any info,
Brian Moore
Bewildered NetBSD Installer