Subject: anyone played with vn devices?
To: None <>
From: matthew green <>
List: current-users
Date: 08/17/1994 10:34:34
[ sparc elc, netbsd 1.0_beta (about a week old) ]

i decided to have a look at the vn stuff last night, trying to set up
a swap file.  it was not sucessful.

i was using

vnconfig /dev/vnd0c /usr/swapfile swap

but that wasn't working because swapon() was getting an EINVAL.  after
grovelling swapon(), i realised that this was because i need vnd (or
something) in my kernel's config.  so i tried something like this..

config          netbsd  root on sd0 swap on sd0 and vnd0

but that didn't work - did not know what to do with vnd0.

splode arch/sparc/conf# _splode_
_splode_:49: netbsd: can't make swap device from `vnd0'
_splode_ has no configurations!

i think that i need an entry in sys/arch/sparc/conf/files.sparc.newconf
like this

major { vnd = 8 }

(there is a `major { sd = 7 }' there, which is where i got the hint for
this), but that just gives me more grief:

splode arch/sparc/conf# _splode_
files.sparc.newconf: device `vnd' used but not defined

now, i'm pretty sure i'm on the right track here, but i don't know
exactly what i need.  the only thing i can see that sd has that vnd
does not is this from files.sparc.newconf

device  sd at tg: disk
file    arch/sparc/scsi/sd.c            sd needs-flag
file    arch/sparc/scsi/sun_disklabel.c sd

except i have no idea what that needs to be for vnd.

i have tried these:

pseudo-device  vnd

and also s/vnd/vnd0/ for both parts, but no luck.