Subject: Re: COM_SW_CLOCAL and "cu" (figured out)
To: John Kohl <>
From: Duncan McEwan <duncan@Comp.VUW.AC.NZ>
List: current-users
Date: 08/05/1994 19:34:06
In response to my comment that setting "local" but not "softcar" on for tty01
in the /etc/ttys file causes "cu -l /dev/tty01" to give the error

 	cu: write: input/output error

Randy Terbush <dsndata!sierra!> said:

> I also have this same problem with or without 'local' set in my /etc/ttys.
> This is running 1.05 or 1.04.

But John Kohl <> said:
> I tried my 1.05 cu this morning, on a line configured:
> tty04 "/usr/libexec/getty tty01"	vt100  off rtscts
> (I have a FlexFAX daemon running on that line, exec'ed from rc.local)
> and it worked fine for me.

And "Martin Husemann" <> said:

> I don't know what version you are using, but with -current from 26 July
> it works fine for me on i386. My /etc/ttys line is:
> # modem under control of mgetty:
> tty01 "/usr/libexec/mgetty tty01"       vt100  off local rtscts
> ...
> Note the "off" in above ttys' line; mgetty is definitely not involved here.
> (It works with "on" too...)

I finally figured out how to make it work for me (with cu 1.04): I needed to
create an /etc/uucp/ports file that looked like this:

	port mymodem
		type modem
		device /dev/tty01
		speed 19200

Now cu knows that the line is connected to a modem it does the right thing
regarding setting CLOCAL on the line.  You don't even have to have either of
local or softcar set in /etc/ttys.

Since cu's behaviour seems to be correct, I'm happy now.  All I need to really
make my day though is to have John or Martin to tell me that cu 1.04 still
works for them even though they don't have an /etc/uucp/ports (or equivelent
HDB or V2 uucp config) file ... :-)