Subject: Re: MSDOSFS problems
To: None <>
From: Drew Hess <dhess@CS.Stanford.EDU>
List: current-users
Date: 08/02/1994 14:57:29
Mike Long writes:
> >Date: Tue, 02 Aug 1994 15:28:39 -0400
> >From: Ken Hornstein <kenh@wrl.EPI.COM>
> >
> [Drew Hess wrote:]
> >>Has anyone else had MSDOSFS problems in the last few days?  I'm running
> >>a July 31 -current/i386 system (binaries and kernel), and whenever I try to
> >>cp a file from a NetBSD partition to an MS-DOS filesystem the machine hangs
> >>and I have to do a hard reset.
> >
> >Just curious; have you verified that the MS-DOS filesystem isn't corrupt?  I
> >used to have similar problems until I ran CHKDSK under DOS and fixed some
> >filesystem inconsistancies.
> I have had similar problems, and CHKDSK found nothing wrong with my
> disk before or after.  I am also using an IDE disk (Western Digital
> WDAC2420); the MSDOS partition was fdisk'ed and formatted using MSDOS
> 6.00, and is 125 MB in size (2K clusters).  When I rebooted into DOS,
> an 0-length entry for the file I had tried to write was in the
> directory; so it created the directory entry OK but choked when it
> tried to write the data.  I didn't get the problem consistently; I was
> able to write some small files to the MSDOS partition before my system
> hung.

Yes, exactly the same thing happened to me.  Trying a 

cp -r dir /dos

copied some of the files (though in one case the files were corrupt) and then
created a 0-length file for the last file in the directory and hung.

Copying just a single file consistently hangs the system.