Subject: Re: problems with source tarballs
To: None <>
From: Martin Husemann <>
List: current-users
Date: 07/31/1994 23:27:46
>    What happens on the kernels I build is this: it goes through all the
>    autoconfiguration stuff, and everything looks like it's working ok.
>    Then it finally gets to the part at the end where it prints the
>    ttymask, biomask, etc. stuff.  Right there it just sits forever,
>    [...]
> Are you still having this problem?

A probably totaly unrelated story: I managed to get this effect once,
and needed a few hours to find the problem. But to keep up the tension
I'll tell you the whole story:

I managed to build working boot disks last Monday (via brute-force
patching fd.c and disklabel.c). I then decided to change my filesystems
to the new 4.4 style. After all the horror stories about fsck -c 2
I made a backup first - using "tar -l -c -v .".

Fsck run fine, I installed new bootblocks and rebooted. The kernel came
up, fsck started and gave up "unexpected inconsitencies, run fsck manualy"
on the "/usr/src/lib/" directory.

I run fsck manualy, let it clear that directory and all else worked fine.
But the fs was heavily fragmented, so I newfs'd it anyway and read back the 
tape. Then I synced and booted...

The kernel loaded, probed everything fine and then the system waited forever,
nothing happend. I had a kernel debugger, so I broke into it and looked
at "ps": init was running two times, so obviously it tried to fork sh for
/etc/rc but couldn't.

After booting from floppy and looking around (and replacing /bin/sh and
/sbin/init invain) I found an empty /dev directory:

Tar -l does not recurse into other filesystems. I use this option to avoid
recursion on /kern/rootdev. Since I have fdesc union-mounted to /dev,
tar won't backup /dev. Ooops.

After rebuilding /dev the system booted fine...


P.S.: please, no comments about tar vs. dump; you just have to use
      both of them the right way.

UNIX - An operating system similar to OS-9, but with less functionality
and special features designed to soak up excess memory, disk space and
CPU time on large, expensive computers.
                                            -- OS-9 Glossary