Subject: None
To: None <>
From: None <>
List: current-users
Date: 07/24/1994 20:26:42 writes:
> I cannot get my com ports to work with ANY current utilities.
> cu gives me the cu: write input/output error if i try to use that..
> I KNOW the kludge about sleep 4000 </dev/com0  but seriously.. how are you
> supposed to NORMALLY interface the com ports with this program??

Ordinarily, when the com port is opened, it blocks until the DCD
line is high on the serial port.  This is intended for dial-in use,
so a getty isn't spawned until a call comes in, and so the connection
is closed if the carrier is lost.

To use the port for dial-out use, add the "softcar" flag to the
appropriate line in /etc/ttys (see the tty(5) man page).  For

tty00   "/usr/libexec/getty std.9600"   unknown off softcar

That makes the driver pretend that DCD is always high.

> #2
> Getty is completly useless.  It ignores everything the modem does, sends
> absolutely nothing TO the modem, accepts no input FROM the modem, and general
> ly
> just sits there like a lump. Iv'e tried my old gettytab configs which used
> to work, the new ones supplied with the bins, and spent OVER 12 hours hacking
> at various things to get it to do SOMETHING..

If dial-in isn't working, then the DCD line is probably not going
high.  Maybe your modem is not configured correctly, or your cable
doesn't have the DCD line connected.

> would someone PLEASE explain to me HOW to set this thing up. This makes 
> no sense to me, considering it all worked just peachy before you "fixed" it.

Before, the driver essentially ALWAYS had "softcar" on.  This worked
well for dial-out, and sort-of worked for dial-in, although if a
dialed-in user lost carrier, the connection would not be terminated
and the next caller would be wherever the first person left off.
Major security hole.

Email:           | Brown University
PGP Key: finger       | Dept of Computer Science