Subject: Can't make boot floppies
To: None <>
From: Martin Husemann <>
List: current-users
Date: 07/10/1994 23:04:51
I played around with Christos' version of the mkboot script, but am unable
to build a working set of disks. I'm using -current from yesterday (July 9).

The images generated by the script when dd'd to disk won't boot.

So I tried disklabel to make a bootable disk myself - but this failed:

> [/tmp] root > disklabel -w -B -b /usr/mdec/fdboot -s /usr/mdec/bootfd /dev/fd0a floppy3
> disklabel: ioctl DIOCSDINFO: Input/output error

and a bunch of kernel messages.

I didn't care, since cgd told us, disklabel won't work on floppies, but
they would be usable anyway. So I tried to boot from the floppy - nothing
happend. (This has worked before, I made my 0.9a boot disk this way...)

I was in doubt, so I used brute force:

> cd /usr/mdec; cat fdboot bootfd | dd conv=sync of=/dev/fd0a bs=512

This gave me a bootable disk without a disklabel. I booted from it and
the bootstrap loader appeared. While it asked for the kernel to boot, I
replaced the floppy with the kernel-copy disk generated by Christos'
Script (kernel.fs). The bootstrap loader rejected it because of a 
missing disklabel :-(

So I don't see any way to get a working set of boot disks right now...