Subject: 3c509 again
To: current-users <>
From: Manuel Bouyer <>
List: current-users
Date: 06/29/1994 20:05:36
	Some time ago, i told about problems whith NetBSD and a 3c509 ethernet 
adapter on an ISA box. Some peoples said that they had no problems whith
eisa boxes.
Now i have an eisa box, and i have made some tests. Here they are:

ftp whith a sun4, SunOS 4.1.3 or hp9000/700, hp-ux 9.01 getting a 2Mb file:

getting this file to /dev/null: i get transfer rates of 1M/s whith both
hp and sun.

getting this file to a scsi disk, whith a bustek 445 scsi adapter (VLbus),
i get 800 Ko/sec 

getting this file to a scsi disk, whith a adaptec 1542b scsi adapter (isa),
or to an ide disk, i get between 20 and 50 Ko/s. When hash is on, i can see that
data comes by 'packets' of variable size (between 1 and 200 Ko); the transfer
stop for 1/10 to 1 sec between each packets.

The adaptec is a little slower than the bustek.
I have done this tests whith both isa and eisa boxes, this didn't change
anything. Putting the file instead of getting it gives the same result.

Here is my hardware configuration:
486 dx 33/66, 16 Mo ram.
dmesg says this:
NetBSD 0.9a (manu.i486) #1: Sun Jun 26 21:08:00 MET DST 1994
  CPU: i486DX (486-class CPU)
  real mem  = 16384000
  avail mem = 14192640
  using 225 buffers containing 921600 bytes of memory
  pc0 at isa0 port 0x60-0x6f irq 1: color
  com0 at isa0 port 0x3f8-0x3ff irq 4: ns82450 or ns16450, no fifo
  com1 at isa0 port 0x2f8-0x2ff irq 3: ns82450 or ns16450, no fifo
  lpt1 at isa0 port 0x378-0x37f: polled
  wdc0 at isa0 port 0x1f0-0x1f7 irq 14
  wd0 at wdc0 drive 0: 240MB 895 cyl, 10 head, 55 sec <Conner Peripherals 240MB - CP30254>
  fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
  fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
  bt0 at isa0 port 0x330-0x333 irq 11: version 3.3, sync, parity, 16 mbxs
  scsibus0 at bt0
  bt0 targ 0 lun 0: <SEAGATE ST11200N SUN1.059500> SCSI2 direct fixed
  sd0 at scsibus0: 1005MB, 1872 cyl, 15 head, 73 sec, 512 bytes/sec
  ep0 at isa0 port 0x300-0x30f irq 10: aui/utp address 00:20:af:f7:a5:ee
  npx0 at isa0 port 0xf0-0xff: using exception 16
  biomask 4840 netmask 600 ttymask 1a

I tried this whith NetBSD-current, tar_files of 16 april, and 26 jun.
I have exactly the same problem whith both.

The adaptec was on irq 11, port 0x330 too.
I've also tried whith ep0 on irq 7, this didn't change anything.

On the same hardware, linux always gives 700ko/sec, even whith /dev/null.

Any ideas ? If someone suggest some changes to the kernel, i can test them.

Manuel Bouyer, Ecole Nationale Superieure de Techniques Avancees, Paris