Subject: Re: more info on fsck -c 2 crash/failure to clean up.
To: Andrew Wheadon <>
From: Jason Thorpe <>
List: current-users
Date: 06/27/1994 21:27:26
Hmmm...I've been thinking about this whole fsck -c 2 thing...The 
'problem' partitions I've seen seem to be root filesystems, etc.  You're 
booting off of a floppy and doing this to an unmounted filesystem, 
right?  I'd think that doing this to / while it's mounted is a *REALLY* 
bad idea...

On Mon, 27 Jun 1994 13:01:16 -40962758 (MET DST) (Andrew Wheadon) wrote:

 > I have come across the same problem. The fsck -c 2 worked fine for my sd0 and sd1
 > partitions but failed on my two wd0 partitions.  (wd0a boot partition, wd0e /var)
 > It just rebooted when trying to convert the partition. I then tried it on the wd0e
 > partition to the same effect.
 > If I just fsck -y /dev/rwd0a it says it has repaired the file system but doesn't
 > actually seem to do anything at least if I reboot and then run fsck again it
 > produces the same error.
 > If I fsck -y -c 2 /dev/rwd0a it will reboot just the same as it did the first
 > time I tried converting, it also doesn't seem to do any changes.
 > a) How can I repair the two partitions ?
 > b) Can I meanwhile continue using the partitions for normal work or would that
 >    be causing a large mess ?
 > Cheerio.
 > -- 
 > The cost of living hasn't affected it's popularity. (unknown)
 > current	release=doc hostbase=/src base=/usr \
 > prefix=/usr backup delete use-rel-suffix ; updated midday MET NetBSD-current

Jason R. Thorpe                         754-1554
OSU CS Support                    CSWest Room 12                     737-5567
      'These are my opinions and not necessarily those of anyone else.'
            NetBSD/Symmetry - Coming soon to a Sequent near you!