Subject: fsck -c 2 , superblock etc.
To: None <>
From: Andrew Wheadon <>
List: current-users
Date: 06/27/1994 13:56:38
I ran across the same problem as Bill Sommerfeld with the superblock being
messy and the alternate block not being updated. (Since my mail was
coming in in a perculiar order it took a little before christos's hack
arrived) I then used christos hack to get fsck to accept the file-systems
as clean.

Unluckily fsck -c 2 is still causing an immediate reboot and failing
whenever I try it on my two wd0 partitions (wd0a boot, wd0e /var)
fsck -c 2 worked fine on my sd0 and sd1 partitions.

- Is this a common problem ?
- Is there a common fix ?
- Does one have to boot from a floppy/different device in order for
  fsck to work ?
- Has anybody succeeded in 'fsck -c2 /dev/rawrootpartition' ?

Any hints/help ?

On a second note --- are multiple 'rdumps' to the same non-rewinding
tape on a network a reliable way of archiving or is it better to use
tar, if one wants to archive multiple partitions without using multiple
Gigabyte tapes ?
i.e. does anybody else do it the same way ?
The cost of living hasn't affected it's popularity. (unknown)
current	release=doc hostbase=/src base=/usr \
prefix=/usr backup delete use-rel-suffix ; updated midday MET NetBSD-current