Subject: Re: floppy driver woes w/June 11th current
To: Ken Hornstein <>
From: Michael L. VanLoon -- Iowa State University <>
List: current-users
Date: 06/24/1994 12:07:39
Ken wrote:
>>I have a BusLogic 747S w/floppy controller; that's what I have my drives
>>plugged into.  Are there any other BusLogic 747S users out there who can
>>write to their floppies under a recent -current?

I wrote:
>I haven't tried it in a couple months, but last time I did it worked
>just fine.  Not that this sheds any light on why it *doesn't* work,
>but I know at some time in the not-too-distant past it did work.

I just tried it last night and got all sorts errors of while trying to
mount an MS-DOS floppy (yes I have msdos fs config'd into my kernel),
and while trying to disklabel a floppy for NetBSD.  About a screenful
of errors each time.  This is with my floppy drive connected to the
floppy controller on my bt747s (and with a kernel and binaries from
May 1st).

I got to thinking about it, and the last time it worked correctly, I
had my floppy drive plugged into the built-in floppy controller on my
motherboard, and not the one on the bt747s.  I can boot off the floppy
drive now, so I know there isn't a conflict as far as DOS is concerned
(I currently have the motherboard floppy controller disabled, and the
bt747s floppy at the primary address).

I would like to use the floppy controller on the bt747s since it
supports 2.88MB floppies.  But I'll switch back to the motherboard
controller temporarily, since I haven't actually ordered a 2.88MB
floppy drive, yet.  In the mean time, I'm going to take a stroll
through the technical ref. guide and see if it has anything to say
about why the BusLogic floppy controller would act differently than
the motherboard controller.  Anyone have any initial ideas that might
help?  I'm not guaranteeing that I'll have time to authoritatively
track down the proble.


 Michael L. VanLoon                 Iowa State University Computation Center                    Project Vincent Systems Staff
  Free your mind and your machine -- NetBSD free Un*x for PC/Mac/Amiga/etc.