Subject: Re: restore(8) broken
To: None <>
From: Thorsten Lockert <tholo@SigmaSoft.COM>
List: current-users
Date: 06/18/1994 01:14:10
>    restore(8) is unable to read back dumps created with both the
>    previous and the current version of dump(8)...  What gives?
> Why didn't you include the output from restore(8) to demonstrate what
> it does?

Sorry, I just got long far enough with an old version of restore(8)
to make it possible to use script(1).

> I just tried it (again) on trinity, and it works fine for me.

Still doesn't work here.

> I could imagine that it might fail if you built it with the old version
> of dumprestore.h that redefined the DT_* symbols.

I checked that, no go.  *sigh*

Anyhow, here's the output from script:

Script started on Sat Jun 18 01:02:53 1994
bash$ restore tvf /usr/var.dump
Verify tape and initialize maps
Tape block size is 32
Dump   date: Fri Jun 17 22:14:11 1994
Dumped from: the epoch
Level 0 dump of /var on
Label: none
Extract directories from tape
. is not on the tape
Root directory is not on tape
abort? [yn] y
dump core? [yn] n
bash$ exit

Script done on Sat Jun 18 01:03:12 1994

The behaviour is the same regardless of what options you give
(restore, extract, list) or wether or not the dump is created
with the current dump(8) or the immediate previous version
(from before the FS changes).

Thorsten Lockert  |   |
Postbox 435       |   |  Universe, n.:
N-5001 Bergen     |        |          The problem.
Norway            | |