Subject: Re: anyone seen this
To: None <>
From: Mark P. Gooderum <>
List: current-users
Date: 06/15/1994 10:14:37
> Excerpts from mail: 14-Jun-94 Re: anyone seen this Mark P.
> Gooderum@aggrega (410)
> > > ld -Bshareable -Bforcearchive  -o libc_pic.a 
> > > ld: libc_pic.a( RRS text relocation at 0x21595 for
> > "SYS_async_daemon"
> > > 
> > > 
> > > I am running up-to-date ld and gas.
> > I ran into this trying to build the Cygnus GCC...I haven't tried 2.5.8 yet.
> > Any .o build with gcc would give these errors when referencing external 
> > symbols in a shared library.
> Gcc 2.5.8 gave pages of them.  The resultant compiler  (with all these
> complaints) still manages to get through stages 2 and 3 of the GCC build.
> 				Andrew

I should mention that these were warnings also...I still was able to build
executables that ran.

The message comes from a line in "claim_rrs_relocation()" in rrs.c of ld:

	if (rp->r_address < text_start + text_size)
		warnx("%s: RRS text relocation at %#x for \"%s\"",
			get_file_name(entry), rp->r_address, sp->name);

The warning is just that, the code continues and does it's thing.
The function only appears to be called when doing a shared object relocation
of non-PIC code or when resolving a reference to shared library from
non-relocatable code.

Could anyone more in the know on these things give a pointer to what the
problem is and what might need to be changed to fix it?