To: None <>
From: Brian Buhrow <>
List: current-users
Date: 06/01/1994 07:20:24
	I'm in the process of upgrading my system from Mid January sources
to current sources.  As the first step, I downloaded and compiled the
kernel and config sources as of May 30, 1994.  The kernel built itself with
no hitches and I thought I was well on my way to a successful upgrade, when
I tried booting from the new kernel.  I got a message that said it couldn't
mount root.
	I realize that this is probably due to the off_t changes that 
took place some time back, but I don't remember what people were  supposed
to do to bring their filesystem into line with the current kernel.  As a
first step, I tried changing the boot blocks, but this did not work.
	Can someone give me a pointer as to what I must upgrade to run the new
Here is my configuration file for a  486DX2 (66 MHZ) 16MB of memory, BT445s
SCSI controller, two 16550a UARTS, and a cp30540 Conner SCSI drive.
Any comments, pointers as to where I should go next would be greatly

# GENERICAHBBT -- Generic machine w/ahb and bt drivers -- distribution floppy
#	$Id: GENERICAHBBT,v 1.25 1994/01/06 12:07:50 cgd Exp $

machine		"i386"
cpu		"I386_CPU"
cpu		"I486_CPU"
timezone	8 dst
maxusers	40
options		"COMPAT_43"
options		"TCP_COMPAT_42"
options		MSDOSFS
options		KERNFS
options		SCSI
options		"MATH_EMULATE"
options "COMPAT_09"
options		"COMPAT_NOMID"
options "NMBCLUSTERS=1024"
options		KTRACE
options		FIFOS
options		"USER_LDT"
options GATEWAY

config		netbsd	root on wd0 swap on wd0 and sd0

controller	isa0

device		pc0	at isa? port "IO_KBD" irq 1
device		com0	at isa? port "IO_COM1" irq 4
device		com1	at isa? port "IO_COM2" irq 3
device		com2	at isa? port "IO_COM3" irq 5

device		lpt0	at isa? port "IO_LPT3" irq 7
device		lpt1	at isa? port "IO_LPT1"
device		lpt2	at isa? port "IO_LPT2"

controller	wdc0	at isa? port "IO_WD1" irq 14
disk		wd0	at wdc0 drive ?
disk		wd1	at wdc0 drive ?

controller	fdc0	at isa? port "IO_FD1" irq 6 drq 2
disk		fd0	at fdc0 drive ?
disk		fd1	at fdc0 drive ?

#device		wt0	at isa? port 0x300 irq 5 drq 1

controller	bt0	at isa? port "IO_BT0" irq 11
master		scsibus0 at bt0
disk		sd0	at scsibus0 slave ?
disk		sd1	at scsibus0 slave ?
disk		sd2	at scsibus0 slave ?
disk		sd3	at scsibus0 slave ?
tape		st0	at scsibus0 slave ?
tape		st1	at scsibus0 slave ?
disk		cd0	at scsibus0 slave ?
disk		cd1	at scsibus0 slave ?

controller	ahb0	at isa? irq 11
master		scsibus1 at ahb0
disk		sd0	at scsibus1 slave ?
disk		sd1	at scsibus1 slave ?
disk		sd2	at scsibus1 slave ?
disk		sd3	at scsibus1 slave ?
tape		st0	at scsibus1 slave ?
tape		st1	at scsibus1 slave ?
disk		cd0	at scsibus1 slave ?
disk		cd1	at scsibus1 slave ?

controller	uha0	at isa? port "IO_UHA0" irq 11 drq 5
master		scsibus2 at uha0
disk		sd0	at scsibus2 slave ?
disk		sd1	at scsibus2 slave ?
disk		sd2	at scsibus2 slave ?
disk		sd3	at scsibus2 slave ?
tape		st0	at scsibus2 slave ?
tape		st1	at scsibus2 slave ?
disk		cd0	at scsibus2 slave ?
disk		cd1	at scsibus2 slave ?

controller	aic0	at isa? port 0x340 irq 11 drq 6
master		scsibus3 at aic0
disk		sd0	at scsibus3 slave ?
disk		sd1	at scsibus3 slave ?
disk		sd2	at scsibus3 slave ?
disk		sd3	at scsibus3 slave ?
tape		st0	at scsibus3 slave ?
tape		st1	at scsibus3 slave ?
disk		cd0	at scsibus3 slave ?
disk		cd1	at scsibus3 slave ?

#device ed0 at isa? port 0x280 irq 9 iomem 0xd0000
#device ed1 at isa? port 0x250 irq 9 iomem 0xd8000
#device ed2 at isa? port 0x300 irq 10 iomem 0xcc000
device el0 at isa? port 0x300 irq 9
#device ep0 at isa? port ? irq ?
#device ie0 at isa? port 0x360 irq 7 iomem 0xd0000
#device is0 at isa? port 0x320 irq 10 drq 7
device		sb0	at isa? port 0x220 bio irq 7 drq 1 vector sbintr

device		npx0	at isa? port "IO_NPX" irq 13

pseudo-device	ether
pseudo-device	log
pseudo-device	loop
pseudo-device	pty	48
pseudo-device	sl	1
pseudo-device	speaker
pseudo-device	bpfilter
pseudo-device	ppp
pseudo-device	audio

--- End of forwarded message from "Brian Buhrow" <>