Subject: diskless booting
To: None <>
From: Steven Reiz <>
List: current-users
Date: 05/05/1994 13:54:22
I know it's a FAQ but I can't seem to find a working answer so...

I've tried booting NetBSD-cur-i386 diskless, using a NetBSD-cur-i386
machine as server as well. It failed in the middle of the tftp-kernel
stage. Is this supposed to work and if so, how? (Which loader used on
DOS, which config file for the diskless kernel?)
There is supposed to be a diskless(8) manpage but I haven't found it.

I've tried two loaders on DOS, both combined with bootpd from
/usr/src/libexec/bootpd, the first is netboot.bin from
/usr/src/sys/arch/i386/netboot, which only passes the rarp stage if
I do a tcpdump rarp as well (!), then successfully starts loading the
kernel with tftp, after loading the text the loader hangs.

This may be because the config of that kernel is incorrect (I used a
normal kernel, not knowing what the diskless config should be),
but I expected the loader to load the data segment as well, and the
kernel doesn't seem to be called at all.

The second loader I tried is the one from FreeBSD, which passes the rarp
stage without any problems, but after 
Loading /tftpboot/cfg.
it gives
Executable too large.
Unable to load config file.

Thanks for any help, and if there is interest I'll summarize.