Subject: Re: Dumb SLIP question.
To: None <,>
From: Mark P. Gooderum <>
List: current-users
Date: 05/04/1994 10:36:13
I wrote a script to do this...

I use kermit and have the script suspend kermit after connecting.
Using kermit you can give it a very sophsiticated login script
including looping, retries, etc.

Anyways after the script suspends, then I run something like:

	sliplogin foo-slip < /dev/tty01

The only thing I've found is that sliplogin wont run my host specific
login/logout file, only the general one.  Some day I'll look into this.

Another issue is that I'm still working on getting automatic
hangup when slattach/sliplogin dies.  I'm still searching for the
right combo of tty options and modem config.

Of course the fun part is I'm also running flexfax on the same modem, so
I've got to kill that first.

This all worked great until upgrading to the 4/28 sources (and the 5/2 which
I just finished) from about 3/15 current.

Since then dial in is hosed.  Flexfax hangs saying "waiting for modem to
come ready" or using getty it runs once and drops straight into login.  If
I kill the getty/login, init never respawns it, no matter how many HUPs
it gets.

Probably realated is that I get *lots* of silo overflow errors,
even when the modem is idle, and I never got any before (internal at 38.4k for now).

Anyone else seen this?

Finally, does anyone have a version the the "COM_BIDIR" patch that works with
a post mid-April current?  I tried hand adpating an old one but a few areas,
notably the open code, have just changed too much to be able to know what to

Otherwise current works well for me, and outgoing works fine, but incoming
is dinked.  (For the no-knowing, flexfax opens the line in w/o waiting for
carrier and turns *off* auto answer, it then watches for "RING" from the
modem and forces it on line, but it's not even getting that far for now).

I'll have a lot more info after some debugging tonight.