Subject: Various questions about current.
To: None <>
From: Greg Cronau <>
List: current-users
Date: 04/29/1994 02:47:20
	Sometime around the end of March, various sources convinced me that
NetBSD was the One-True-Path to enlightenment :-). I decided to take a
crack at it and downloaded the floppy images and the distribution sources.
	However, I was using a Bustek 747S controller that only partially
worked with 0.9. After many letters I obtained the quick-and-dirty patch
to 0.9 that got my 747S going enough to finish the install and bring the
system up. I also exchanged a little mail with an overworked member of
the netbsd group who convinced me to go with netbsd-current because it
should work with my 747S alot better than 0.9.
	Unknown to me, I picked the absolutely *worst* time to try this,
the weekend of April 1 through 3rd. Friday evening and into Saturday I
downloaded the source tar files, and ended up with the 3/27 source tars,
and then during Saturday evening into Sunday(the 3rd), I downloaded the
binary tar files. When I got done, I found somebody had put new tar files
in place while I had been ftping and I had half of one rev and half of
another! <argh> Not knowing which was which, I scrapped them all and
downloaded the binary tars again. After I little fiddling with the
new boot blocks and the new kernal I was able to get all of the April 3
binaries installed and the system up and running.
	I then tried to build a kernel and ran into another problem. Between
my 3/27 sources and the 4/3 binaries, the config program and the devices
had made the change between "struct isa_device" and "struct cfdriver" or
something like that. By this time, the April 6th. source tar files were
available, so I tossed the 3/27 sources and downloaded the 4/6 sources.
	At this point I could now build a working kernel. I backed everything
up and then proceded to build *everything*. Did it twice too, because
the 4/6 sources actually built using 4/3 include files the first time.
I encountered the following problems:
1.) Lex didn't build, but that was easily fixed by doing the cp initscan.c
2.) Crontab wouldn't build. I seem to remember that it had a problem with
    a "uid_t" somewhere that was pretty easily fixed.
3.) Groff had *many* problems and I just said fuck-it.

	These is also a couple of interesting problems along this route:
1.) Between 0.9 and the 4/6 current, a number of binaries have changed where
    they live. This results in ocaisonally not getting the binary you think
    you should.
2.) A couple of *include* files have also moved around! I seem to remember
    a couple of files moved between /usr/include/machine and somewhere else.

I reccomend to anyone trying this, to do an "ls -altr" on all your dirs
afterwards and clean out any old trash that's been left laying around.

	At this point I am running on a system built entirely from 4/6 sources
and it's been remarkably stable(Thanks Guys!), I even built *all* of X11R5
with XFree-2.1 with only a couple of hitches. I looked at my include files
and "off_t" appears to be defined as "quad_t" which is "long long".

	I saw a piece of email about 10 days ago about all the "off_t" voodoo
that said in effect:
	"Right now the code is going to be in a transitory state with some
backwards compatibility magic for about 2 weeks and then I'm going to
rip all the compatibility stuff out and if you arn't up to date by that
point you're going to be in trouble." or something close to that, I can't
find the piece of mail in question.
	My question is: do the 4/6 sources I have now, have enough of this new
stuff in for the changover, or am I going to be in trouble soon as with
respect to new code updates?

	I am not yet in a position from which I can run SUP. Part of this
project is that I want to run netbsd on 2 small 386-40 boxes that I will
use as SLIP routers between my house and work using Hayes 28.8k modems,
but until I get that going, no SUP.