Subject: ft_qbmask.val is undefined in /usr/src/sbin/fsck/setup.c
To: None <>
From: David Bryan Burgess <>
List: current-users
Date: 04/27/1994 15:34:32
Hi all,

My sup finally worked ast night (SLIP didn't squash anything for a change) so
I am reasonably certain that everything worked OK.  I decided to rebuild the 
kernel and user-land binaries while I write a test for class tomorrow night.

In the kernel build, I routinely rebuild the .../floppy/... stuff.  I found that I couldn't get fsck to compile.  I figured it was just an include file
problem, so I installed the new include stuff.

Everything seems to be exactly as it should be, except that now the compile
complains that 'val' is trying to be a member of a structure that isn't a
structure.  It seems as if fsck is expecting fs_qbmask to be a struct;
unfortunately, it is now a quad_t.  quad_t is a long long, not a four
(or is it two) byte/word/whatever structure.

It's not a big deal, I just wanted to make sure that someone else knows.  If
I had the time and knew how it SHOULD be, I would wire it up.  As it is, I will
gladly waiy for someone else to fix it :-).

TSgt Dave
Asst Vice Sub Chairman for membership, Midwestern NetBSD Users Consortium.
And To the volunteer treasurer:  No; Aruba is NOT on the speaking schedule 
                                 for this summer.  Why? :-)