Subject: Help! Problems with X on -current
To: None <>
From: Brian Moore <>
List: current-users
Date: 04/16/1994 05:49:30
I'm having problem using the XFree86 2.1 with the April 5 sources.  I've tried
both the binaries from laas on sun-lamp, but both exhibit the same problem.  My
problem is that when using xdm, the first login session works fine, but if I
logout, xdm will hang forever trying to get hold of the screen.  Here's what
running 'xdm -nodaemon -debug 9 &' looks like.

Before XOpenDisplay(:0)
display manager caught SIGUSR1
select returns -1.  Rescan: 0  ChildReady: 0
hung in open, aborting
giving up on server
select returns -1.  Rescan: 0  ChildReady: 1
signals blocked, mask was 0x0
Manager wait returns pid: 446 sig 0 core 0 code 4
Display exited with OPENFAILED_DISPLAY, try 0 of 4

And then it hangs forever.  I have tried playin around with several options,
but to no avail.  If anyone can give me a clue to what's happening or what I
should look for, it would be most appreciated.  I've listed some other
information below that might help.

Brian Moore

System: Gateway 2000 4DX2-66V (JX-30 motherboard, I think )
Memory: 16MB
Video card:  ATI Ultra Pro 2MB VRAM
Network: Slip connection on tty01
Input: mouse on tty00

Kernel configured for shared memory, DUMMY_NOPS, XSERVER and UCONSOLE.

> cat /etc/ttys
# console       "/usr/libexec/getty Pc"         pc3     off secure
vga     "/usr/libexec/getty Pc"         pc3     on secure
tty00   "/usr/libexec/getty std.9600"   unknown off secure
tty01   "/usr/libexec/getty std.57600"  dailup off secure
tty02   "/usr/libexec/getty std.9600"   unknown off secure
tty03   "/usr/libexec/getty std.9600"   unknown off secure

> ls -l /dev/vga /dev/ttyp[0-4]
crw-rw-rw-  1 root  wheel    1,   0 Apr 16 05:36 /dev/tty
crw-------  1 uucp  wheel    8,   0 Apr 16 00:57 /dev/tty00
crw-------  1 uucp  wheel    8,   1 Apr 16 00:50 /dev/tty01
crw--w----  1 ziff  tty      5,   0 Apr 16 00:58 /dev/ttyp0
crw--w----  1 ziff  tty      5,   1 Apr 16 05:24 /dev/ttyp1
crw--w----  1 ziff  tty      5,   2 Apr 16 05:37 /dev/ttyp2
crw--w----  1 ziff  tty      5,   3 Apr 16 05:46 /dev/ttyp3
crw-------  1 ziff  tty     12,   0 Apr 16 00:57 /dev/vga