Subject: Snapshot Report - 9th April tar_files
To: None <>
From: Alistair G. Crooks <>
List: current-users
Date: 04/12/1994 08:06:35
Snapshot report.

Me: (Alistair G. Crooks)

Source: tar_files, 9th April 1994, from

Base version of NetBSD: 0.9.

Upgrade from previous -current: yes, 6th April tar_files from

Machine specifics: 486DX2/66, 16MB RAM, 340 MB IDE (Conner), VGA card

Other software: None, as yet...

Tar files integrity: good.

Additional things to do during upgrade: None

Any warnings during compilation: None

Any problems during make: 
Well, my system seems to have become spontaneous-reboot prone again. 
There were 4 whilst I was compiling /usr/src/lib/, and all happened
during the nroff phase on the man pages.  I've also got a reproducible
vm fault whenever I run /usr/libexec/makewhatis, so I finally got the
finger out, installed new boot blocks - version 1.19 - (my kernel with
DDB in was too large to be booted by the 0.9 boot blocks).  More anon.


Changes from 6 April tar_files:
(This is taken from the CHANGES file on sun-lamp - last update on 9 Apr 94)

        change the way syscalls with quad arguments are implemented. (cgd)
        change stdio's fpos_t to an off_t. (cgd)
        added hilinfo and grfinfo, from Utah, for the hp300. (cgd)
        modify ftpd to support non-anonymous chrooted users.  patches
                from  (cgd)
        updated our set*id() syscalls to match the POSIX security model,
                with _POSIX_SAVED_IDS.  fixed a few bugs, in the process,
                and obsoleted (i.e. moved into libc/compat-43) several
                functions and (former) syscalls. (cgd)
        add a MNT_USER flag, for mounts made by users. (cgd)
        modify mount_msdos so that the uid, gid, and permissions masks for
                files in the FS are inherited from the mounted-on dir,
                and are user-settable.  Also, allow users to mount MS-DOS
                file systems. (cgd)
        ns32k support for ld (thanks to Matthias Pfaller). (pk)


0.  Not much has changed since the last snapshot report, so hopefully
this week will be very short.

1. Michael VanLoon pointed out that vmstat is broken this week - I think
it's just some symbols that have been elided in the latest config changes.

2.  If anyone hasn't upgraded to the latest -current for any reason,
please remember to get a statically-linked copy of gzip and tar,
preferably on a floppy somewhere - don't lose the floppy like the last
time, Crooks - so that you could always recover from the binary
snapshots on sun-lamp if necessary.

3.  Has anyone in the US dragged down the new XFree86 2.1 libs and
binaries from They've been compiled to run with the off_t

4.  Installing new bootblocks proved to be relatively painless for me.
If you know how to do this, then skip this paragraph. If you don't, then
read on...

a) cd /usr/mdec ; save a copy of the old boot blocks in case all else fails
b) cd /sys/arch/i386/boot ; make install
this will install the new boot blocks in /usr/mdec
c) make sure you've got a copy of your disc-type in /etc/disktab
if not, you'll have to construct it yourself with the aid of disklabel
d) disklabel -w -r <hard disc special> <hard disc pack name>
this will install the primary and secondary boot areas from /usr/mdec
onto your disc of choice.

Simple really, but I couldn't find any documentation on it anywhere.
I would also advise trying it out on a floppy first, so that you can
check that the bootblocks work.

5.  Details of the vm fault to anyone upon request.

6.  I ran a make in /usr/src/share, (which was rebooting on me
before).  That also gave me a spontaneous reboot when run with a
kernel with DDB in it, and it didn't go into the kernel debugger. 
From this, I'm wondering if it's something to do with the swap area on
my IDE disc, bad-sector forwarding etc.  The easiest way to sort this
would be to move to SCSI, but that's solving the symptoms rather than
curing them. I'll beaver away at this one a bit more.

Alistair G. Crooks (                      +44 252 346377
Amdahl European HQ, Dogmersfield Park, Hartley Wintney, Hants RG27 8TE, UK.