Subject: Re: weird mt scsi tape stuff
To: Michael L. VanLoon -- Iowa State University <>
From: None <>
List: current-users
Date: 04/12/1994 08:51:13
> For instance, if I load a tape and tar onto it, things go fine.  I did
> a tar verify and a tar --diff afterwards and everything was pretty
> much peachy.  Using "mt -f /dev/rst0 rewind" worked as advertised.
> However, "mt -f /dev/nrst0 fsf" would always put the tape in an
> unwritable mode.  I could read it after that, but every write would
> fail with "Invalid command" or something like that, with a syslog
> message:
> Apr 11 00:58:55 MindBender /netbsd: st0(bt0:6:0): illegal request

Actually, I recently noticed something like this as well.  I tried to
"mt fsf" past a dump file, and then write another dump, and it acted
the same way as it does when the the tape is write-protected: It just
silently ignores everything written to it without reporting an error(!)

This was with 940405's kernel, by the way (after the major SCSI changes).

uha0 targ 1 lun 0: <ARCHIVE VIPER 2525 25462-007> SCSI1 sequential removable
st0 at scsibus0: rogue, density code 0x0, 1024-byte blocks, write-protected

Email:           | Brown University
PGP Key: finger       | Dept of Computer Science