Subject: weird mt scsi tape stuff
To: None <>
From: Michael L. VanLoon -- Iowa State University <>
List: current-users
Date: 04/11/1994 02:13:07
I sent this last night, but never saw it show up... hopefully
resending it won't be a duplicate...

I've been trying to coax an old Exabyte 8mm tape drive that I borrowed
into doing some backups on my machine.  For the most part it seems to
work.  But sometimes weird things happen.

For instance, if I load a tape and tar onto it, things go fine.  I did
a tar verify and a tar --diff afterwards and everything was pretty
much peachy.  Using "mt -f /dev/rst0 rewind" worked as advertised.
However, "mt -f /dev/nrst0 fsf" would always put the tape in an
unwritable mode.  I could read it after that, but every write would
fail with "Invalid command" or something like that, with a syslog

Apr 11 00:58:55 MindBender /netbsd: st0(bt0:6:0): illegal request

If I rewound and ejected the tape, then stuck it back in and just used
tar to read past the first backup, I could write a second backup with
no problems.  But using mt fsf would make the tape unwritable.

Also, after it got into this weird state, sometimes it would give me
"Invalid command" when I tried other mt commands too (like rewind),
but if I tried the command a second time, it would usually work.

I'm using a bt747s with a kernel built Friday from the 4/8 sup.  Is
the tape handling really buggy?  Or is there something else that could
explain all this odd behaviour?


 Michael L. VanLoon                 Iowa State University Computation Center                    Project Vincent Systems Staff
  Free your mind and your machine -- NetBSD free Un*x for PC/Mac/Amiga/etc.