Subject: OUCH!
To: None <>
From: Space Case <>
List: current-users
Date: 04/07/1994 00:26:07
Come, let me tell you a story...

Well, I thought I had it going pretty good.  I had got my Mac up to
-current (as of a couple weeks ago), and had just gotten SUP going.
The problems with off_t had just about subsided, and a few files that
might help with a problem I was having in experimenting with the
kernel had just been loaded.  Sounds like the time is right to go
for the upgrade (I do so love living dangerously!)

So I start off by building the kernel. Seems to work ok. Didn't get
any of the errors I had been getting recently. Hmm.. ps is broken
again. Well, it'll get fixed in the rebuild.

Next, I build make & install it. (I'm running the new kernel here,
looks pretty good.) Then I install the includes and build ar, ranlib,
and ld. I figured I could install those, make a new, build
the kernel again and from there, a make build.

Never got that far. I started installing from where I ended up (ld)
and everything was going fine until it got to, whereupon the
process crashed. (I wish I'd saved that error message). Anyway, the
next thing I tried, I got a "no" message. Hmm.  I type in the
install command by hand, and it seems to work ok. I tried a couple
of commands (whoami), and it gives me the error message:
    Cannot map anonymous memory

Huh??? Most any command I try gives that error, except the ones that
direcly operate on the filesystem (ls, chmod, etc.)  Ecch -- bogus So I move it aside, pull a tarfile off cray-ymp, and extract out of it. No good either. It stalls; I can ctrl-c out of the
commands that use it, but it doesn't do anything. Even with the old
kernel (though that doesn't surprise me too much.)

So, at the moment, I'm hosed. I manage a couple dozen Sys-V machines,
but aspects of BSD surprise me. Like the concept of databases for
passwd and termcap. Shared libraries (though Silicon Graphics is
starting to move in that direction, I haven't had my hands on it yet.)

And now What in the world? I figure it must be a thing for
loading shared libraries for those executables that have them. And
what's with that error message??? Anonymous Memory??

Now if I were a BSD whiz, I'd probably be able to figure out a way
to use this system with static binaries until I got it fixed, but
I'm not, so....

Well, I'm going to take a break and consider my options..
And if anyone has ideas, I'd certainly appreciate help.

~Steve "Just roadkill on the information superhighway" Allen

Steven R. Allen -
How come wrong numbers are never busy?