Subject: core dump trying to build gcc in March 20th sources
To: None <>
From: Duncan McEwan <duncan@Comp.VUW.AC.NZ>
List: current-users
Date: 03/23/1994 10:41:34
I am trying to build the system from scratch from the March 20th sources.  I

	cd /usr/src/include; make install
	cd /usr/src/share/mk; make install
	cd /usr/src/lib; make && make install

which all worked fine.  Then I tried to build and install a new compiler
before rebuilding everything from scratch, but during the linking of cc1 got
the following error:


===> cc1
cc   -o cc1 c-parse.o c-lang.o c-lex.o c-pragma.o c-decl.o c-typeck.o c-convert.o c-aux-info.o c-iterate.o /usr/src/gnu/usr.bin/gcc2/common/obj/libcc1.a -lgnumalloc
cc: Internal compiler error: program ld got fatal signal 11
*** Error code 1

*** Error code 1


I tried various things, including building and installing the version of ld
from the current sources, and building and installing a new version of
libgnumalloc.  I also resupp'ed again just an hour ago which got updated
versions of bcmp.S, memcmp.S and regcomp.c in libc, so I rebuilt and installed
a new libc.  None of these made any difference.  Finally, wondering if my
version of the ld sources was corrupt, I ftp'ed the ld directory from, but according to diff the two directories were the same.

A version of ld compiled with debugging symbols gives the following output:

	gdb /usr/bin/ld ld.core
	Core was generated by `ld'.
	Program terminated with signal 11, Segmentation fault.
	Cannot access memory at address 0x10021040.
	#0  0x3a75 in enter_file_symbols (entry=0x74000)
    		at /usr/src/gnu/usr.bin/ld/ld.c:1258
	1258                    } else if (p->n_un.n_strx &&

Since I haven't seen any other reports of this problem, I assume I have done
something wrong.  This is the first build I have done since early February, so
it is possible that some other utility important to the build process needs
updating.  Any pointers as to where to look would be much appreciated.