Subject: Snapshot Report - 26 Feb tar_files
To: None <>
From: Alistair G. Crooks <>
List: current-users
Date: 03/01/1994 06:49:47
Snapshot report.

Me: (Alistair G. Crooks)

Source: tar_files, 26th February 1994, from

Base version of NetBSD: 0.9.

Upgrade from previous -current: yes, 19 Feb tar_files from

Machine specifics: 486DX2/66, 16MB RAM, 340 MB IDE (Conner), VGA card

Other software: Havard Eidnes' shared XFree86 2.0, from 9 February 1994.

Tar files integrity: good.

Additional things to do during upgrade:

Any warnings during compilation: various, not noted

Any problems during make: see below.


Changes from 19 Feb tar_files:
(This is taken from the CHANGES file on agate - last update on 25 Feb 94)

        add da30 port (yet another m68k machine). (paulus)
        change hardclock() to take a "clockframe *" instead of a
                "clockframe". simplifies things for some ports (deraadt)
        very strange hack in vnode.h to ensure that inodes are double
                aligned in struct vnode. Various new processors, including
                sparc, require structures to be double-word aligned (deraadt)
        panic() is now a varargs function (deraadt)
        sparc: sparc port works! Ported from 4.4 to NetBSD by myself.
                Much thanks to Chris Torek <> for the
                original code from 4.4, and Paul Kranenburg for helping
                with the userland code. (deraadt)
        in tty.c, undo a flow control bug introduced months ago. (deraadt)
        modload & friends mistakenly were compiled with a -DKERNEL. Please
                don't do this. (deraadt)
        i386: MAKEDEV no longer creates symbolic links in /dev. (deraadt)
        i386: more if_ep.c bugs fixed (deraadt)
        sparc: don't cache dma memory. fix from Chris Torek (deraadt)
        sparc: NetBSD/sparc is capable of compiling it's own kernel, so the
                support for cross-compiling the kernel goes away (deraadt)
        sparc: proper /dev/MAKEDEV. derived from hp300. (pk & deraadt)
        amiga: proper /dev/MAKEDEV. cleaned up from original by Markus and
                Ty Sarna apparently (deraadt)
        split /etc/ttys per architecture, mostly because /dev/console is
                done in different ways (deraadt)
        sparc: use normally ordered pty major numbers (deraadt)
        tty.c's VMIN/VTIME code was missing an untimeout(). fix from
                freebsd. (deraadt)
        support for the "lookup" keyword in resolv.conf. See the man
                page for more details (deraadt)
        sun3: sun3 port boots and runs init, spawns a shell and will even
                run ls upon request.  needs drivers and some stability
                work.. (glass)

0. There's a new version of wd.c in -current. It's much improved. The
one in the tar_files doesn't work however, so remember to pick up wd.c
if you're picking up the tar_files. Specifically, wd.c from the 27th
February works - the 25/26th Feb one doesn't. You've been warned.

1.  There's a new version of the Mitsumi CD-ROM driver. 

2.  Herb Peyerl and Charles Hannum rightly pick me up for bum info in
the SCSI table that was posted last week, which should look like:

aha1542b isa                 aha1542.c
aha1542c/cf isa              aha1542.c
aha1742 eisa                 aha1742.c  
aha1742 eisa                 aha1742.c
bt445   vlb                  bt742a.c
          need v3.37 bios4.47      
          need v3.63 bios4.72      
          (These BIOS levels are for the standard bt742a.c driver)
          (For later BIOS levels, use Michael VanLoon's modified driver)
bt542   isa (mod'd driver)   aha1542.c
bt545   isa (old ones only)  aha1542.c
bt742   eisa                 bt742a.c
bt747   eisa (mod'd driver)  bt742a.c
ultra34f vlb                 ultra14f.c
ultra14f isa                 ultra14f.c

[The Adaptec 2742 is not supported, and may not be in future due to
Adaptec's refusal to release "proprietary information" about the board.]

If anyone has any more to add to this list, please drop me a line.

(There was some discussion over the best SCSI board to purchase. 
General reasoning was that Adaptec support wasn't good for non-DOS
problems, and re the 2742 issue.  The Ultrastore has jumpers for
everything, which can be a pain.  The Bustek boards have had
favourable reports.  Please note that I'm just condensing other
people's opinions here, all you lawyers out there.)

3.  The current list of supported Ethernet cards looks like:

3c501                   isa     if_el                     (
3c503 (and probably 3C507, but I can't actually test it)  (mycroft)
3c509                   isa     if_ep   bnc/aui/utp.      (tdr)
3c579                   eisa            doesn't work yet. (tdr)
WD 8390-based cards     isa     if_ed                     (mycroft)
SMC 8390-based cards    isa     if_ed                     (mycroft)
NE1000, NE2000          isa     if_ed                     (mycroft)
NE2100                  isa     if_is                     (mycroft)
AT&T StarLAN (82586-based cards)                          (mycroft)
BICC Isolan                                               (mycroft)

If anyone has any more to add to this list, please contact me.

4. pccons.c has undergone a fairly major overhaul. For the first time
ever on pumpy, I don't have the LED problem, for which I'm very grateful.
Thanks, Charles. There's no problem on boot, but in X, if I hit the CAPS
LOCK key, I'll get a "pc: timeout updating leds", but the CAPS LOCK key
actually functions OK. Mark Weaver has the message on boot sometime,
but always in X. However, apart from the message, functionality is OK,
and Mark's was on a Gatway 2000. Sounds like this pccons.c is a big
step in the right direction, with perhaps a timing value to be changed
still. Drew Hess has got problems - his keyboard doesn't work with the
new pccons.c. As an afterthought, you'll have to have the kernel option
FAT_CURSOR in your config file to get the block cursor on your screen -
otherwise it's the underline, which was unsuitable for my LCD screen.

5. config has also been changed, and you may get better serial port
performance now.

6.  Matthieu Herrb's updated the binaries for XFree86 on  They now use a shared libm, so if
you have a coprocessor, just make the specific libm (by removing a
comment in src/lib/libm/Makefile) and go. 

7. Sun3 - the growth of NetBSD continues, with a bootable Sun3 port.
It still needs a lot more work (read: he turned off the assertions)
but this is a great start.  Needs device-drivers most of all.

8.  IDE discs - the story continues.  Eric Hvozda (
wants to create a list of working/failing IDE drives - this is before
the new wd.c was incorporated into -current.  (As an aside, I was
having problems with my IDE drive, but think it's hardware, and not
software.  If I'm careful about sync'ing and shutting down pumpy,
everything's hunky dory.  If I don't, then I've got to pick up the
pieces.  The drive has its own on-board cache.  Conner CP30344.)

0.9 Quantum LP240A alone        OK      (
0.9 Maxtor 7245AT alone         OK      (
0.9 7245AT and LP240A
        root and swap on both, root and swap only on either one I got
        lost of stray ISA INTR 7 with this setup, only when the LP240
        was the master.  No problems when it was the slave.  wd.c
        patch made this setup totally unusable.  (
0.9 Maxtor 7345AT               OK      (
0.9 7245AT and 7345AT
        root and swap on the 7345AT; only boot blocks on 7245AT. 
        Works great, no more stray ISA INTR 7 at all.  It was almost as if the
        Quantum disk was the problem to start with.  Still no problems if
        master and slave are switched.  went back to orginal wd.c; 7245AT is
        the master.                     (
cur Quantum 240
        increase timeout from 400000 to 800000, and it's OK (
        (Note that I had the problems with the Q240 as the sole drive, and
        when I had the Q240 running dos as drive 0 and a WDC 340 with netbsd
        as drive 1).
cur Quantum 240AT
        3 partitions of 80 MB each.  First partition is Linux, second is
        NetBSD /usr/src, third is NetBSD root and swap.  I never saw the
        problem on 0.9, but I only used it for a short time (I seem to
        remember that I had some lockups, though).  On -current (Jan/Feb) it
        happened to me three times: the first 2 times it trashed /usr/src,
        which I could restore rather easily, the third time it junked the root
        partition.  Have not tried since then.
        I also used a hacked wd.c from 0.9 for some time in -current, and if I
        remember correctly, I only had lockups but no corruption with that
        driver.  So this might be a potential workaround (I rather have some
        lockups than total disk corruption), and also a good starting place. (Dirk Steinberg)
cur Seagate ST1144A (master) and WD Caviar 2340C        OK
        master: seagate ST1144A 125 M
                2 partition: 40 M Microsucks DOS
                             85 M NetBSD - 8M /, 8M sw, rest /usr
        slave: wd caviar WD2340C 330 M (Since december 93)
                2 partition: 150 M DOS
                             180 M NetBSD - 10M /var, 20M sw, rest /usr2
        Before that wd.c patch the drives sometimes got hung. Lately I used
        a wd.c hacked by Theo Deraadt, now using (since yesterday) -current's
        wd.c. Current wd.c can now survive fsck's parallel mode somehow.
        No data loss yet. Szabolcs Szigeti (PinkPanther) <>
cur Conner CP30344			OK
	I've had a few problems (with duplicate inodes reported by fsck),
	upon recovery after a crash, with both 0.9 and -current. I think
	it's hardware, and is to do with onboard cache. Not easily reproducible.
	Alistair Crooks (

9.  Tape backup - Michael Graff ( made his first
backup with a Colorado Memory Systems Jumbo 250, so the ft driver must
be working.  Thanks to whoever did this work - I've lost your name,
I'm afraid.  He's looking for similar people with similar hardware to
start cleaning up the driver.

10.  If you're new to -current, or are looking for an answer to what
you may think is a FAQ, check the mailing list archive on

11.  telnet's been changed.  If you'd like to output a ':' in the
login banner, then use '\c' rather than '\:' as getty uses the libc
getcap routines. 

12.  Nothing's been said, but I see that mount_portal and mount_lofs
exist.  (Manual pages say they were first introduced in 4.4BSD).

13.  I used -pipe to compile again, and, once again, had a spontaneous
reboot whilst I was formatting the libc manual pages.  Nothing else
was going on at that time.  Does groff still have funny memory usage
patterns?  I'll have a look this week.

14.  A piece of advice to people, too. The scripts in /etc often change,
but I for one am far too important and busy to have to bother with minor
details such as these. I was bitten by that this week, and actually got
the finger out and updated what I could. Definitely recommended. (I would
say that, wouldn't I?).

General verdict: Quite a few changes, nothing too tricky, just make sure
you've (a) got an old kernel around in case the new pccons.c bites you
and (b) got a new copy of wd.c if you're that way inclined.

And the usual afterthoughts:

1.  So nobody wanted a copy of gofer?

Alistair G. Crooks (                      +44 252 346377
Amdahl European HQ, Dogmersfield Park, Hartley Wintney, Hants RG27 8TE, UK.