Subject: Re: SCSI problems, the sequel
To: None <dhess@CS.Stanford.EDU>
From: Randy Terbush <sierra!randy>
List: current-users
Date: 01/30/1994 05:50:00
  >> Chris G. Demetriou writes:

> actually, i wasn't under the impression that any of the buslogic
> controllers other than the bt742 worked with -current.

  >> My BT445S VLB SCSI works just fine with the bt742 driver, as Julian assured
  >> me it would before I purchased it.

Can you tell me more about your configuration?  Julian also told me
the BT445S would work, but I am finding that it doesn't, and and losing
much hair of the whole deal.  I had similar problems to the originator
this thread when trying to boot with the FreeBSD kernel.  

I have:
        16mb RAM
        HP C2247 1.0G SCSI
        Motherboard is an Orchid SuperBoard
        I am running (try to) NetBSD-current 1-15 kernel

I have tried every possible bus speed setting for the card.
When the system boots, the controller is found, the drive information
is printed, then I hit the following printf.

cmd fail

if (sd_scsi_cmd(unit, (struct scsi_generic *)&scsi_cmd,
	    sizeof(scsi_cmd), (u_char *)&scsi_sense, sizeof(scsi_sense),
	    2000, flags) != 0) {
		printf("could not mode sense (4) for unit %d\n", unit);
		printf(" using ficticious geometry\n");
		sectors = sd_size(unit, flags);

Randy Terbush
UUCP: netcomsv!dsndata!randy

---- "It's all the same f*cking day, man!" ---- Janis Joplin ----