Subject: tar_files from 24th Jan
To: None <>
From: Alistair G. Crooks <>
List: current-users
Date: 01/27/1994 00:32:11
I haven't seen this fly past, so I'm reposting.

Snapshot report.

Me: (Alistair G. Crooks)

Source: tar_files, 24th January 1994, from

Base version of NetBSD: 0.9.

Upgrade from previous -current: yes, 15 Jan tar_files from

Machine specifics: 386DX/40, 8MB RAM, 340 MB IDE (Conner), VGA card

Other software: Mark Weaver's shared XFree86 2.0, from 1 December 1994.
(from I think).

Tar files integrity: good.

Additional things to do during upgrade: none

Any warnings during compilation:
/usr/src/lib/libc/stdio/vfprintf.c, line 478, cast from a pointer
to an integer of a different size.

Any problems during make: 
1. rpcgen placed the wrong include file path into the programs in
/usr/src/lib/librpcsvc/*.c, when it creates them from the .x files.
I rebuilt rpcgen, and installed it (having already installed the new
libc), and then tried to build librpcsvc. Everything went fine.
2. complained that df wouldn't compile
with the -current of January 25.  This didn't happen for me -
/usr/src/bin/df/df.c compiled fine - but I had rebuilt and installed
libutil before I tried to build df.
3. /usr/src/usr.bin/ref wouldn't compile, as it references files in
the elvis directory. But elvis has gone, although a sighting may occur
in a supermarket near you soon. I just removed the reference to ref from


From Problem 2 above, maybe it's just me, but when I upgrade, I first
make the include files, then I build and install libc, libmalloc, gas,
ld and gcc2, and then do the while of /usr/src/lib, then the user
programs and then rebuild the kernel - I find it's a good way to try
to make sure that everything's in sync.


1. New VM stuff means that top and ps now show a more accurate representation
of the resident size and total memory size than previously. Nice.

2. Elvis isn't there anymore. It's been replaced by nvi (the binary
is just called vi). Seems nice, giving windowing onto files, shell
windows, and other very nice features.

3. Kernel still seems robust.

4. Various people have complained about keyboards locking on
Gateway 2000s and Trackpoint something-or-others on -current versions
since the beginning of January. Workaround apparently is to hammer
on the keyboard during boot.

5. I was griping about the wd driver puking all over my partitions.
I haven't been able to recreate this since last Wednesday, I think, so
I assume it was something that I did. Mea culpa, and sorry for the
inconvenience caused.

6. Can't get Novell NE2000-clone card recognised by probe on boot, but
I haven't tried to do anything about this. Again, probably my fault.
[Come on, Crooks, get the finger out and look at it.]

7. The shared-X stuff is good (disc-spatially-challenged here), but some
of the clients don't work with my shared libraries. We really need
someone to look after trailing XFree86 and NetBSD-current sources,
making sure the two are compatible.

General verdict: nice, robust, and warm fuzzy feelings. Thanks to all

And as afterthoughts:

1. I've got postgres 4.1 compiled on Jan 15th -current. I've got problems
when I try to initialise the database. Anyone want to help me look into
2. I've got the September 93 version of sam compiled and running under
XFree86 2.0 with shared libraries. Anyone want to play with it?
3. Wine 0.7 dumps core on me - I'm going to give up on this one, I
think, as there are other versions of solitaire that I could use.
4. Are these snapshot reports useful to anyone?

Alistair G. Crooks (                      +44 252 346377
Amdahl European HQ, Dogmersfield Park, Hartley Wintney, Hants RG27 8TE, UK.