Subject: strange lockups in X
To: None <>
From: Roland McGrath <>
List: current-users
Date: 01/22/1994 17:26:00
I have been having this problem for several days.  I just supped this
morning and recompiled my kernel today; I supped and recompiled the
entire system from scratch (with current tools) and reinstalled the
programs yesterday.

When I run my normal X setup, with several clients at once, some from the
net, and including a changing background picture frob going all the time
(at nice -20) so the X server never sits still, after a short time of use
(before today's kernel it happened immediately) I can do X things and type
into my xterms, but the shells seem not to be able to fork; I can keep
using my emacs until it tries to fork a subprocess, at which point it
wedges completely.

The X server I'm using is XFree86-2.0; many of the utilities are from
binaries someone on this mailing list made available for FTP shortly after
the shared library implementation was fully integrated.  They have worked
fine for me until a week or so ago.

Anyone else have this sort of problem?