Subject: Re: 09 Jan -current
To: Jim Babb <>
From: Luke Mewburn <>
List: current-users
Date: 01/21/1994 12:47:07
> My system has 2 IDE drives,  a Conner 340M and a Quantum 240M.
> Also, a fast VESA-bus IDE controller, 486-DX 33, 16MB ram.

> with NetBSD-current (as of Jan 9), I could not access the 2nd drive at all
> (I tried both as the master - no dice either way).  As soon as I try
> to do something simple like 'disklabel -r' or 'fdisk' of wd1,
> I get 3 timeout messages from the wd driver, and then a complete hang.

In very early january I first attempted to goto current. At the time, 0.9
was on a Quantum LP240 - the only drive in the machine. After getting current
compiled, I kept getting errors on bootup with 3 wdc0 timeouts then lockup.
There were two different types of messages, one of one type, and two of the
	wdc0: timeout in wdintr WDCS_BUSY
	wdc0: timeout in wdintr WDCS_DRQ

At that point, I gave up - thinking that there was a wd.c change that
introduced a bug some stage earlier.

A week after that, I bought a Western Digital ADC340. I got current-jan09
or whatever up and running (and was very impressed when it came up. Then I 
plugged the quantum in. On boot up, I got the same error messages but
it kept going. THen, any attempt to access wd1x (the LP240) hung the

I don't think that quantum have broken board logic, but it appears
that wd.c just doesn't work for those drives. Any ideas?

> Jim

``Concealment is never as hard as people think, you          Luke Mewburn
  must understand that. It's action while hiding that's    <>
  the hard part''
        -- Coyote, in Kim Stanley Robinson's `Green Mars'